You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avro.apache.org by "Scott Banachowski (JIRA)" <ji...@apache.org> on 2009/11/21 23:32:39 UTC

[jira] Created: (AVRO-234) cleanup recent checkins

cleanup recent checkins
-----------------------

                 Key: AVRO-234
                 URL: https://issues.apache.org/jira/browse/AVRO-234
             Project: Avro
          Issue Type: Improvement
          Components: c++
            Reporter: Scott Banachowski
         Attachments: AVRO-234.patch

This is a patch to clean up some miscellaneous stuff:

change the name of a class
change a function argument from pointer to reference
fix indenting on json printing for map and array
call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AVRO-234) cleanup recent checkins

Posted by "Scott Banachowski (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AVRO-234?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Banachowski updated AVRO-234:
-----------------------------------

    Attachment: AVRO-234.patch

revised patch, added default argument values for the code-generated layout structure contructors

> cleanup recent checkins
> -----------------------
>
>                 Key: AVRO-234
>                 URL: https://issues.apache.org/jira/browse/AVRO-234
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>         Attachments: AVRO-234.patch, AVRO-234.patch
>
>
> This is a patch to clean up some miscellaneous stuff:
> change the name of a class
> change a function argument from pointer to reference
> fix indenting on json printing for map and array
> call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AVRO-234) cleanup recent checkins

Posted by "Scott Banachowski (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AVRO-234?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Banachowski updated AVRO-234:
-----------------------------------

    Attachment: AVRO-234.patch

> cleanup recent checkins
> -----------------------
>
>                 Key: AVRO-234
>                 URL: https://issues.apache.org/jira/browse/AVRO-234
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>         Attachments: AVRO-234.patch
>
>
> This is a patch to clean up some miscellaneous stuff:
> change the name of a class
> change a function argument from pointer to reference
> fix indenting on json printing for map and array
> call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AVRO-234) cleanup recent checkins

Posted by "Scott Banachowski (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AVRO-234?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Banachowski updated AVRO-234:
-----------------------------------

    Status: Patch Available  (was: Open)

> cleanup recent checkins
> -----------------------
>
>                 Key: AVRO-234
>                 URL: https://issues.apache.org/jira/browse/AVRO-234
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>         Attachments: AVRO-234.patch
>
>
> This is a patch to clean up some miscellaneous stuff:
> change the name of a class
> change a function argument from pointer to reference
> fix indenting on json printing for map and array
> call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AVRO-234) cleanup recent checkins

Posted by "Scott Banachowski (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AVRO-234?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Banachowski updated AVRO-234:
-----------------------------------

    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

Committed revision 883978.

> cleanup recent checkins
> -----------------------
>
>                 Key: AVRO-234
>                 URL: https://issues.apache.org/jira/browse/AVRO-234
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>         Attachments: AVRO-234.patch, AVRO-234.patch, AVRO-234.patch
>
>
> This is a patch to clean up some miscellaneous stuff:
> change the name of a class
> change a function argument from pointer to reference
> fix indenting on json printing for map and array
> call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AVRO-234) cleanup recent checkins

Posted by "Scott Banachowski (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AVRO-234?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Banachowski updated AVRO-234:
-----------------------------------

    Attachment: AVRO-234.patch

I've revised the patch with further changes.  The main goal of these newest changes is to make the interface for using the dynamic schema resolution parser to look more like the one for the regular parser.  

Also, I renamed some classes and functions, which makes the diff seem big, but most of it is just a search/replace.
I also broke out some of the classes into their own files, as a result there are added (and renamed) files.

to apply the patch, do the following in the shell:

touch src/c++/impl/ResolverSchema.cc
touch src/c++/api/ResolverSchema.hh
touch src/c++/api/ResolvingReader.hh
touch src/c++/api/Layout.hh
svn mv src/c++/api/Instruction.hh src/c++/api/Resolver.hh
svn mv src/c++/impl/Instruction.cc src/c++/impl/Resolver.cc
svn add src/c++/impl/ResolverSchema.cc
svn add src/c++/api/ResolverSchema.hh
svn add src/c++/api/ResolvingReader.hh
svn add src/c++/api/Layout.hh
patch -p0 < AVRO-234.patch


> cleanup recent checkins
> -----------------------
>
>                 Key: AVRO-234
>                 URL: https://issues.apache.org/jira/browse/AVRO-234
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>         Attachments: AVRO-234.patch, AVRO-234.patch, AVRO-234.patch
>
>
> This is a patch to clean up some miscellaneous stuff:
> change the name of a class
> change a function argument from pointer to reference
> fix indenting on json printing for map and array
> call reserve() on vectors before pushing data to them

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.