You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@drill.apache.org by "Daniel Barclay (Drill) (JIRA)" <ji...@apache.org> on 2015/06/13 07:55:00 UTC

[jira] [Commented] (DRILL-3285) Split DrillCursor.next(), clean up DrillCursor for clarity

    [ https://issues.apache.org/jira/browse/DRILL-3285?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14584460#comment-14584460 ] 

Daniel Barclay (Drill) commented on DRILL-3285:
-----------------------------------------------

Reviews are at:
- part 1: https://reviews.apache.org/r/35413
- part 2: https://reviews.apache.org/r/35414
- part 3: https://reviews.apache.org/r/35415
- part 4: https://reviews.apache.org/r/35416
- part 5: https://reviews.apache.org/r/35417


> Split DrillCursor.next(), clean up DrillCursor for clarity
> ----------------------------------------------------------
>
>                 Key: DRILL-3285
>                 URL: https://issues.apache.org/jira/browse/DRILL-3285
>             Project: Apache Drill
>          Issue Type: Bug
>          Components: Client - JDBC
>            Reporter: Daniel Barclay (Drill)
>            Assignee: Daniel Barclay (Drill)
>         Attachments: DRILL-3285.AllPts.1.patch.txt, DRILL-3285.Pt1.1.patch.txt, DRILL-3285.Pt2.1.patch.txt, DRILL-3285.Pt3.1.patch.txt, DRILL-3285.Pt4.1.patch.txt, DRILL-3285.Pt5.1.patch.txt
>
>
> Clean up the mess in DrillCursor, namely the poorly named (and of course undocumented) flow-control flags and the flag-laden next() method.
> ==========
> DRILL-3285: Part 1--Prep., Hygiene:  Mainly, adding comments.
> Added/edited comments:
> - field doc. comments
> - method doc. comments
> - branch/block comments
> Removed unused recordBatchCount and getRecordBatchCount().
> Added logger call for spurious batch.
> Various cleanup:
> - Cleaned up logger.
> - Added "final" on updateColumns().
> - Wrapped some lines
> - Misc. comment whitespace.
> ==========
> DRILL-3285: Part 2--Renaming.
> Renamed state/control-flow members:
> - started -> initialSchemaLoaded
> - first -> beforeFirstBatch
> - redoFirstNext -> returnTrueForNextCallToNext
> - finished -> afterLastRow
> Renamed other items:
> - changed -> schemaChanged
> - currentBatch -> currentBatchHolder
> - DrillResultSet's currentBatch -> batchLoader
> ==========
> DRILL-3285: Part 3--Invert beforeFirstBatch -> ! afterFirstBatch.
> ==========
> DRILL-3285: Part 4--Reorder fields, updateColumns.
> ==========
> DRILL-3285: Part 5--Split old hacky next() into separate methods.
> Split the original public next() method (which was hacked to handle an extra,
> initial call to read the schema batch) into:
> - new loadInitialSchema() (for handling the call for the schema)
> - modified next() (for handling normal calls from ResultSet.next())
> - new private nextRowInternally() (for common code)
> Pulls invariant afterFirstBatch up out of bogus-batch loop.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)