You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by "Vinod Kone (JIRA)" <ji...@apache.org> on 2014/03/06 20:48:48 UTC

[jira] [Commented] (MESOS-1024) wire up observe end point to Repairer class in master

    [ https://issues.apache.org/jira/browse/MESOS-1024?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13922964#comment-13922964 ] 

Vinod Kone commented on MESOS-1024:
-----------------------------------

commit 0fbd2a85a4d832c68dee1a6f169b1a1d9af158a6
Author: Charlie Carson <ch...@gmail.com>
Date:   Thu Mar 6 11:47:23 2014 -0800

    Refactored Cluster::Master::start methods
    
    There are currently two overloads of the Cluster::Masters::start
    function.  One takes a argument of AllocatorProcess* and the other
    does not.  The AllocatorProcess* overload serves two purposes:
    1) it allows an alternative implementation of AllocatorProcess to be
    passed (i.e. a mock)
    2) it changes the destruction timing so that the passed in argument
    can outlive the master.
    
    Beyond that, the two functions are identical.   This changes the
    parameter to be Option<AllocatorProcess*> and allows all the logic
    to be in one method.  The old function exists for back-compat but
    now simply forward by passing in None() to the other function.
    
    This is for two purposes:
    1) reduce code duplication
    2) position the code so that we can also optionally pass in a mock
    repaier.
    
    Review: https://reviews.apache.org/r/18370


> wire up observe end point to Repairer class in master
> -----------------------------------------------------
>
>                 Key: MESOS-1024
>                 URL: https://issues.apache.org/jira/browse/MESOS-1024
>             Project: Mesos
>          Issue Type: Sub-task
>          Components: master
>            Reporter: Charlie Carson
>            Assignee: Charlie Carson
>            Priority: Minor
>
> we want the observe HTTP endpoint to call into the Repairer component in master's observe method.  for now the actual Repairer will continue to just log, but this will enable me to add a mock Repaier and verify that the end point passes the values over to master->repairer correctly.



--
This message was sent by Atlassian JIRA
(v6.2#6252)