You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@reef.apache.org by "Sergiy Matusevych (JIRA)" <ji...@apache.org> on 2016/08/15 21:14:20 UTC

[jira] [Comment Edited] (REEF-1532) Pass Time object instead of numeric timestamp in Timer methods

    [ https://issues.apache.org/jira/browse/REEF-1532?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15421687#comment-15421687 ] 

Sergiy Matusevych edited comment on REEF-1532 at 8/15/16 9:14 PM:
------------------------------------------------------------------

Issue [REEF-1527] introduces the new methods (that take {{Time}} objects) and deprecates the old ones (that operate with {{long}} timestamps). This issue ([REEF-1532]) should be closed after release 0.16 when we remove the deprecated methods. 


was (Author: motus):
Issue [REEF-1527](https://issues.apache.org/jira/browse/REEF-1527) introduces the new methods (that take {{Time}} objects) and deprecates the old ones (that operate with {{long}} timestamps). This issue ([REEF-1532](https://issues.apache.org/jira/browse/REEF-1532)) should be closed after release 0.16 when we remove the deprecated methods. 

> Pass Time object instead of numeric timestamp in Timer methods
> --------------------------------------------------------------
>
>                 Key: REEF-1532
>                 URL: https://issues.apache.org/jira/browse/REEF-1532
>             Project: REEF
>          Issue Type: Improvement
>          Components: REEF-Common
>            Reporter: Sergiy Matusevych
>            Assignee: Sergiy Matusevych
>              Labels: deprecation
>
> Methods in {{Timer}} interface, e.g. {{Timer.isReady()}} accept long timestamp, but in all contexts where the Timer implementations are used, we operate with Time objects. That leads to awkward chain calls, e.g.
> {code:java}
> timer.getDuration(event.getTimeStamp())
> {code}
> instead of shorter and more readable and type safe
> {code:java}
> timer.getDuration(event)
> {code}
> We propose to deprecate methods that take {{long}} timestamp in release 0.16 in favor of parameters of type {{Time}} and remove old methods in teh subsequent release.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)