You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@flink.apache.org by Maximilian Michels <mx...@apache.org> on 2016/09/02 13:25:20 UTC

[DISCUSS] Storm 1.x.x support in the compatibility layer

This should be of concern mostly to the users of the Storm compatibility layer:

We just received a pull request [1] for updating the Storm
compatibility layer to support Storm versions >= 1.0.0. This is a
major change because all Storm imports have changed their namespace
due to package renaming.

If we merged this pull request we would have two modules, one for
Storm < 1.0.0 and one for Storm >= 1.0.0. This would require a lot of
duplicate work for the Flink community.

Thus, I would suggest to remove the Storm compatibility for < 1.0.0
and focus on supporting 1.x.x versions of Storm.

What do you think? In particular, how do Storm users think about this?

Cheers,
Max

[1] https://github.com/apache/flink/pull/2452

Re: [DISCUSS] Storm 1.x.x support in the compatibility layer

Posted by "Tzu-Li (Gordon) Tai" <tz...@apache.org>.
I’m not a Storm user, but from the discussion in the Storm version survey it seems like
most of the users that are still using 0.9 or 0.10 are planning to upgrade to 1.0.
Also, the Storm community seems to be planning to end support for older Storm versions.

Because of the complete package renaming, it also doesn’t seem like an easy task to
somehow refactor the current code so we can reuse the older version code for 1.0+ support
(like what we’re currently doing with the Kafka 0.10 & 0.9 connector).

So, I’m leaning towards focusing on supporting 1.0+ Storm versions. The code will
be easier to maintain for the Flink community.

Regards,
Gordon

On September 2, 2016 at 11:28:30 PM, Matthias J. Sax (mjsax@apache.org) wrote:

One thing to consider: there are still many people using Storm 0.9 or  
Storm 0.10.  

There was a recent "Survey" on Storm user list:  
https://mail-archives.apache.org/mod_mbox/storm-user/201608.mbox/%3C5DCE24EC-0E48-4AA1-A700-F2AB48248304%40gmail.com%3E  

Just want to point out, the we might "cut off" those users.  

-Matthias  

On 09/02/2016 03:25 PM, Maximilian Michels wrote:  
> This should be of concern mostly to the users of the Storm compatibility layer:  
>  
> We just received a pull request [1] for updating the Storm  
> compatibility layer to support Storm versions >= 1.0.0. This is a  
> major change because all Storm imports have changed their namespace  
> due to package renaming.  
>  
> If we merged this pull request we would have two modules, one for  
> Storm < 1.0.0 and one for Storm >= 1.0.0. This would require a lot of  
> duplicate work for the Flink community.  
>  
> Thus, I would suggest to remove the Storm compatibility for < 1.0.0  
> and focus on supporting 1.x.x versions of Storm.  
>  
> What do you think? In particular, how do Storm users think about this?  
>  
> Cheers,  
> Max  
>  
> [1] https://github.com/apache/flink/pull/2452  
>  


Re: [DISCUSS] Storm 1.x.x support in the compatibility layer

Posted by "Matthias J. Sax" <mj...@apache.org>.
One thing to consider: there are still many people using Storm 0.9 or
Storm 0.10.

There was a recent "Survey" on Storm user list:
https://mail-archives.apache.org/mod_mbox/storm-user/201608.mbox/%3C5DCE24EC-0E48-4AA1-A700-F2AB48248304%40gmail.com%3E

Just want to point out, the we might "cut off" those users.

-Matthias

On 09/02/2016 03:25 PM, Maximilian Michels wrote:
> This should be of concern mostly to the users of the Storm compatibility layer:
> 
> We just received a pull request [1] for updating the Storm
> compatibility layer to support Storm versions >= 1.0.0. This is a
> major change because all Storm imports have changed their namespace
> due to package renaming.
> 
> If we merged this pull request we would have two modules, one for
> Storm < 1.0.0 and one for Storm >= 1.0.0. This would require a lot of
> duplicate work for the Flink community.
> 
> Thus, I would suggest to remove the Storm compatibility for < 1.0.0
> and focus on supporting 1.x.x versions of Storm.
> 
> What do you think? In particular, how do Storm users think about this?
> 
> Cheers,
> Max
> 
> [1] https://github.com/apache/flink/pull/2452
>