You are viewing a plain text version of this content. The canonical link for it is here.
Posted to oak-issues@jackrabbit.apache.org by "Thomas Mueller (JIRA)" <ji...@apache.org> on 2014/01/15 12:23:20 UTC

[jira] [Comment Edited] (OAK-1157) DS implementation for S3-based DSs

    [ https://issues.apache.org/jira/browse/OAK-1157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13871943#comment-13871943 ] 

Thomas Mueller edited comment on OAK-1157 at 1/15/14 11:22 AM:
---------------------------------------------------------------

[~ajain], the patch seems to contain duplicate changes (see also JCR-3705), would it be possible to shrink the patch?

The patch uses joptsimple (MIT license, "JOpt Simple is a Java library for parsing command line options, such as those you might pass to an invocation of javac."). I wonder if this is really needed?

There are some comments that simply refer to the interface, I wonder if they add value? If not could you remove them? Example:

{code}
+    /* (non-Javadoc)
+     * @see org.apache.jackrabbit.data.Backend#close()
+     */
+    @Override
+    public void close() throws DataStoreException {
+        dataStore.close();
+    }
{code}

There seems to be code duplication. For example, MongoCloudBlobStoreTest.testCombinedIdentifier seems to be a 1:1 copy of the source code of the existing MongoBlobStoreTest. Could this and other duplications be avoided?




was (Author: tmueller):
[~ajain], the patch seems to contain duplicate changes (see also JCR-3705), would it be possible to shrink the patch?

The patch uses joptsimple (MIT license, "JOpt Simple is a Java library for parsing command line options, such as those you might pass to an invocation of javac."). I wonder if this is really needed?

There are some javadocs that simply refer to the interface, I wonder if they add value? If not could you remove them? Example:

{code}
+    /* (non-Javadoc)
+     * @see org.apache.jackrabbit.data.Backend#close()
+     */
+    @Override
+    public void close() throws DataStoreException {
+        dataStore.close();
+    }
{code}

There seems to be code duplication. For example, MongoCloudBlobStoreTest.testCombinedIdentifier seems to be a 1:1 copy of the source code of the existing MongoBlobStoreTest. Could this and other duplications be avoided?



> DS implementation for S3-based DSs
> ----------------------------------
>
>                 Key: OAK-1157
>                 URL: https://issues.apache.org/jira/browse/OAK-1157
>             Project: Jackrabbit Oak
>          Issue Type: New Feature
>            Reporter: Michael Marth
>            Assignee: Thomas Mueller
>             Fix For: 0.15
>
>         Attachments: OAK-1157.patch
>
>
> Related to OAK-805
> I think we need a DS implementation for the lately introduced S3 DS in Jackrabbit 2, so that users of that DS can easily migrate to Oak
> I think it would anyway be a very useful DS implementation to have, also for Oak



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)