You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@ant.apache.org by bu...@apache.org on 2009/09/17 15:37:19 UTC

DO NOT REPLY [Bug 47860] New: ftp task to provide feedback on succeeded/failed transfers

https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

           Summary: ftp task to provide feedback on succeeded/failed
                    transfers
           Product: Ant
           Version: 1.8Alpha (nightly)
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Optional Tasks
        AssignedTo: notifications@ant.apache.org
        ReportedBy: mfrasca@zonnet.nl


when you run the ftp task with attribute skipFailedTransfers set, you don't
receive any feedback on the transfers that were skipped and those than
succeeded.

I'm planning to add a property (or most likely two) that will contain a /pipe/
separated string of all names transferred.

if it was up to me, I would name the two attributes:
skippedItemsProperty, transferredItemsProperty.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

--- Comment #5 from Mario Frasca <mf...@zonnet.nl> 2010-05-04 08:01:01 EDT ---
Created an attachment (id=25397)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=25397)
currenty using this patch.

this modification write the relative path of the files into the property.  not
the absolute remote nor the absolute local paths.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Antoine Levy-Lambert <an...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|1.8.1                       |1.8.2

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Antoine Levy-Lambert <an...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|1.8.0                       |1.8.1

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

J.M. (Martijn) Kruithof <jk...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|ftp task to provide         |[PATCH] ftp task to provide
                   |feedback on                 |feedback on
                   |succeeded/failed transfers  |succeeded/failed transfers

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

--- Comment #4 from Mario Frasca <mf...@zonnet.nl> 2010-05-03 08:24:24 EDT ---
there's a problem with the definition of this property:

when copying files from remote to local, do you want to have the remote or the
local name of each of the transferred files?  if your subsequent action is to
delete the files remotely, you need the remote name.  if you plan to copy them
further or do whatever other action with what you received, you need the local
name.

must think about this and talk with my users...

feedback from users of this site will be used too!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Mario Frasca <mf...@zonnet.nl> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #24288|0                           |1
        is obsolete|                            |

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

--- Comment #3 from Mario Frasca <mf...@zonnet.nl> 2009-09-21 02:09:02 PDT ---
actually better separate file names with a ','
then one can use FileList
(http://ant.apache.org/manual/CoreTypes/filelist.html)

a sample usage:
  <ftp server="${server}" userid="${user}" password="${pass}"
       transferredItemsProperty="transferredfiles"
       action="put" skipFailedTransfers="true"
       remotedir="/test-ftp">
    <fileset dir="./">
      <include name="?"/>
    </fileset>
  </ftp>

  <echo>successfully sent: (${transferredfiles})</echo>

  <delete>
    <filelist dir="./" files="${transferredfiles}"/>
  </delete>

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Stefan Bodewig <bo...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|normal                      |enhancement

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

--- Comment #2 from Mario Frasca <mf...@zonnet.nl> 2009-09-18 01:50:19 PDT ---
(In reply to comment #1)
> Created an attachment (id=24288)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=24288) [details]
> the proposed patch
> 
> actually, I did not test it yet, but this is the idea.

tested now.  it seems to do what I want, except for an obvious bug:

before ignoring the first character of the String value, I should first check
that the string is not empty!

        if (value.length()>0)
            value = value.substring(1);

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Antoine Levy-Lambert <an...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|1.8.0RC1                    |1.8.0

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] [PATCH] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

Antoine Levy-Lambert <an...@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|1.8Alpha (nightly)          |1.8.0RC1

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

DO NOT REPLY [Bug 47860] ftp task to provide feedback on succeeded/failed transfers

Posted by bu...@apache.org.
https://issues.apache.org/bugzilla/show_bug.cgi?id=47860

--- Comment #1 from Mario Frasca <mf...@zonnet.nl> 2009-09-18 00:41:45 PDT ---
Created an attachment (id=24288)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=24288)
the proposed patch

actually, I did not test it yet, but this is the idea.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.