You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ignite.apache.org by Vladimir Ozerov <vo...@gridgain.com> on 2015/04/03 14:24:33 UTC

Ignite component class names.

Hi,

We removed "Grid" prefix from all public API in Ignite. However, we still
have odd namings in internal classes which can be used by plugin
developers. E.g.:

DR:
GridCacheDrManager - DR manager interaface;
GridOsCacheDrManager - Ignite implementation of DR manager;

Cache objects:
IgniteCacheObjectProcessor - interface;
IgniteCacheObjectProcessorImpl - implementation.

It seems to me that we should ensure that all components which can
potentially be exposed to plugin developers should have consistent namings
as well. E.g.:
GridCacheDrManager -> CacheDrManager
GridOsCacheDrManager -> IgniteCacheDrManager (other implementors could
follow [Vendor]CacheDrManager pattern).

If we do not do that now, we will have to preserve these inconsistent names
because their refactoring will brake third-party plugins.

Thoughts?

Re: Ignite component class names.

Posted by Alexey Kuznetsov <ak...@gridgain.com>.
+1

On Fri, Apr 3, 2015 at 7:24 PM, Vladimir Ozerov <vo...@gridgain.com>
wrote:

> Hi,
>
> We removed "Grid" prefix from all public API in Ignite. However, we still
> have odd namings in internal classes which can be used by plugin
> developers. E.g.:
>
> DR:
> GridCacheDrManager - DR manager interaface;
> GridOsCacheDrManager - Ignite implementation of DR manager;
>
> Cache objects:
> IgniteCacheObjectProcessor - interface;
> IgniteCacheObjectProcessorImpl - implementation.
>
> It seems to me that we should ensure that all components which can
> potentially be exposed to plugin developers should have consistent namings
> as well. E.g.:
> GridCacheDrManager -> CacheDrManager
> GridOsCacheDrManager -> IgniteCacheDrManager (other implementors could
> follow [Vendor]CacheDrManager pattern).
>
> If we do not do that now, we will have to preserve these inconsistent names
> because their refactoring will brake third-party plugins.
>
> Thoughts?
>



-- 
Alexey Kuznetsov
GridGain Systems
www.gridgain.com

Re: Ignite component class names.

Posted by Dmitriy Setrakyan <ds...@gridgain.com>.
Agree.

On Fri, Apr 3, 2015 at 5:24 AM, Vladimir Ozerov <vo...@gridgain.com>
wrote:

> Hi,
>
> We removed "Grid" prefix from all public API in Ignite. However, we still
> have odd namings in internal classes which can be used by plugin
> developers. E.g.:
>
> DR:
> GridCacheDrManager - DR manager interaface;
> GridOsCacheDrManager - Ignite implementation of DR manager;
>
> Cache objects:
> IgniteCacheObjectProcessor - interface;
> IgniteCacheObjectProcessorImpl - implementation.
>
> It seems to me that we should ensure that all components which can
> potentially be exposed to plugin developers should have consistent namings
> as well. E.g.:
> GridCacheDrManager -> CacheDrManager
> GridOsCacheDrManager -> IgniteCacheDrManager (other implementors could
> follow [Vendor]CacheDrManager pattern).
>
> If we do not do that now, we will have to preserve these inconsistent names
> because their refactoring will brake third-party plugins.
>
> Thoughts?
>