You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by "Benjamin Mahler (JIRA)" <ji...@apache.org> on 2013/03/12 23:33:13 UTC

[jira] [Resolved] (MESOS-273) Add a Bytes abstraction akin to Duration

     [ https://issues.apache.org/jira/browse/MESOS-273?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Benjamin Mahler resolved MESOS-273.
-----------------------------------

    Resolution: Fixed
    
> Add a Bytes abstraction akin to Duration
> ----------------------------------------
>
>                 Key: MESOS-273
>                 URL: https://issues.apache.org/jira/browse/MESOS-273
>             Project: Mesos
>          Issue Type: Improvement
>            Reporter: Benjamin Mahler
>            Assignee: Benjamin Mahler
>            Priority: Minor
>
> We've accumulated a lot of cruft around amount of memory/disk.
> via benh: "It's really time for a Bytes/Kilobytes/Megabytes/Gigabytes struct. Unlike Duration, maybe it makes sense to just create a single Bytes class as the "base", or maybe call it Bits? Not sure if Size or Data are descriptive enough."
> My thoughts:
> Size: typically refers to number of things (list::size, vector::size, map::size, ...)
> Data: typically refers to the data itself, rather than size (char* data, string data, ...)
> Bytes: although works fine at the unit level, like Seconds, seems odd as the base class (makes me think of actual byte data, rather than # of bytes).
> Duration worked nicely to avoid doing Amount<Time>, however in this case it's tricker to avoid Amount<Data> (  https://github.com/twitter/commons/tree/master/src/java/com/twitter/common/quantity )
> I'd go with Bytes or Bits, preferably Bytes.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira