You are viewing a plain text version of this content. The canonical link for it is here.
Posted to cvs@httpd.apache.org by tr...@apache.org on 2015/05/22 21:09:40 UTC
svn commit: r1681190 - /httpd/httpd/trunk/CHANGES
Author: trawick
Date: Fri May 22 19:09:40 2015
New Revision: 1681190
URL: http://svn.apache.org/r1681190
Log:
remove some entries for fixes recently backported to 2.4.x
Modified:
httpd/httpd/trunk/CHANGES
Modified: httpd/httpd/trunk/CHANGES
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/CHANGES?rev=1681190&r1=1681189&r2=1681190&view=diff
==============================================================================
--- httpd/httpd/trunk/CHANGES [utf-8] (original)
+++ httpd/httpd/trunk/CHANGES [utf-8] Fri May 22 19:09:40 2015
@@ -1,18 +1,6 @@
-*- coding: utf-8 -*-
Changes with Apache 2.5.0
- *) In alignment with RFC 7525, the default recommended SSLCipherSuite
- and SSLProxyCipherSuite now exclude RC4 as well as MD5. Existing
- configurations must be adjusted by the administrator. [William Rowe]
-
- *) In alignment with RFC 7525, the default recommended SSLProtocol and
- SSLProxyProtocol directives now excludes SSLv3. Existing configurations
- must be adjusted by the administrator. [William Rowe]
-
- *) mod_authn_dbd, mod_authz_dbd, mod_session_dbd, mod_rewrite: Fix lifetime
- of DB lookup entries independently of the selected DB engine. PR 46421.
- [Steven whitson <steven.whitson gmail com>, Jan Kaluza, Yann Ylavic].
-
*) mod_ssl OCSP Stapling: Don't block initial handshakes while refreshing
the OCSP response for a different certificate. mod_ssl has an additional
global mutex, "ssl-stapling-refresh".
@@ -23,16 +11,8 @@ Changes with Apache 2.5.0
*) core/util_script: make REDIRECT_URL a full URL. PR 57785. [Nick Kew]
- *) mod_ssl: Check for the Entropy Gathering Daemon (EGD) availability at
- configure time (RAND_egd), and complain if SSLRandomSeed requires using
- it otherwise. [Bernard Spil <pil.oss gmail com>, Stefan Sperling,
- Kaspar Brand]
-
*) http: Add support for RFC2324/RFC7168. [Graham Leggett]
- *) core: Cleanup the request soon/even if some output filter fails to
- handle the EOR bucket. [Yann Ylavic]
-
*) core, modules: Avoid error response/document handling by the core if some
handler or input filter already did it while reading the request (causing
a double response body). [Yann Ylavic]
@@ -55,9 +35,6 @@ Changes with Apache 2.5.0
or force-proxy-request-1.0, and respond with 502 instead of 400 if its
Connection header is invalid. [Yann Ylavic]
- *) http: Make ap_die() robust against any HTTP error code and not modify
- response status (finally logged) when nothing is to be done. [Yann Ylavic]
-
*) mod_proxy_http: Don't establish or reuse a backend connection before pre-
fetching the request body, so to minimize the delay between it is supposed
to be alive and the first bytes sent: this is a best effort to prevent the