You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Paul Brett <pa...@twopensource.com> on 2015/03/31 23:32:12 UTC

Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/
-----------------------------------------------------------

Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.


Bugs: mesos-2332
    https://issues.apache.org/jira/browse/mesos-2332


Repository: mesos


Description
-------

Pull the common container definitions out of PortIsolatorMappingTest for reuse.


Diffs
-----

  src/tests/port_mapping_tests.cpp f4124c3 

Diff: https://reviews.apache.org/r/32659/diff/


Testing
-------

make check


Thanks,

Paul Brett


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Paul Brett <pa...@twopensource.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/
-----------------------------------------------------------

(Updated April 1, 2015, 3:44 p.m.)


Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.


Bugs: mesos-2332
    https://issues.apache.org/jira/browse/mesos-2332


Repository: mesos


Description
-------

Pull the common container definitions out of PortIsolatorMappingTest for reuse.


Diffs
-----

  src/tests/port_mapping_tests.cpp f4124c3e880e043729579a829e1057727741d131 

Diff: https://reviews.apache.org/r/32659/diff/


Testing
-------

make check


Thanks,

Paul Brett


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Mesos ReviewBot <de...@mesos.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/#review78458
-----------------------------------------------------------


Bad patch!

Reviews applied: [32658, 32657, 32656]

Failed command: ./support/apply-review.sh -n -r 32656

Error:
 2015-04-01 01:04:47 URL:https://reviews.apache.org/r/32656/diff/raw/ [4250/4250] -> "32656.patch" [1]
error: patch failed: src/tests/port_mapping_tests.cpp:194
error: src/tests/port_mapping_tests.cpp: patch does not apply
Failed to apply patch

- Mesos ReviewBot


On April 1, 2015, 12:52 a.m., Paul Brett wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/32659/
> -----------------------------------------------------------
> 
> (Updated April 1, 2015, 12:52 a.m.)
> 
> 
> Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.
> 
> 
> Bugs: mesos-2332
>     https://issues.apache.org/jira/browse/mesos-2332
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Pull the common container definitions out of PortIsolatorMappingTest for reuse.
> 
> 
> Diffs
> -----
> 
>   src/tests/port_mapping_tests.cpp f4124c3e880e043729579a829e1057727741d131 
> 
> Diff: https://reviews.apache.org/r/32659/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Paul Brett
> 
>


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Paul Brett <pa...@twopensource.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/
-----------------------------------------------------------

(Updated April 1, 2015, 12:52 a.m.)


Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.


Bugs: mesos-2332
    https://issues.apache.org/jira/browse/mesos-2332


Repository: mesos


Description
-------

Pull the common container definitions out of PortIsolatorMappingTest for reuse.


Diffs (updated)
-----

  src/tests/port_mapping_tests.cpp f4124c3e880e043729579a829e1057727741d131 

Diff: https://reviews.apache.org/r/32659/diff/


Testing
-------

make check


Thanks,

Paul Brett


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Chi Zhang <ch...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/#review78426
-----------------------------------------------------------



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127094>

    s/connectin/listen/?



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127093>

    Maybe useful to put these three lines up where you explain the specific ranges chosen?



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127095>

    Maybe just kill res? 
    
    (a style goal of mesos is to avoid one-off variables as long as it doesn't hurt readability too much)



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127096>

    s/'port'/'validPort'/ ?
    
    here and everywhere else in the comments in this file?



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127098>

    



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127103>

    is this longer than 80 characters? could you check other places?
    
    (btw, support/hooks/pre-commit can check for you)



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/32659/#comment127106>

    2-space indent for line-wrap for assignments.
    
    4-space indent for function definition/invocation 
    
    http://mesos.apache.org/documentation/latest/mesos-c++-style-guide/


- Chi Zhang


On March 31, 2015, 11:11 p.m., Paul Brett wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/32659/
> -----------------------------------------------------------
> 
> (Updated March 31, 2015, 11:11 p.m.)
> 
> 
> Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.
> 
> 
> Bugs: mesos-2332
>     https://issues.apache.org/jira/browse/mesos-2332
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Pull the common container definitions out of PortIsolatorMappingTest for reuse.
> 
> 
> Diffs
> -----
> 
>   src/tests/port_mapping_tests.cpp f4124c3 
> 
> Diff: https://reviews.apache.org/r/32659/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Paul Brett
> 
>


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Paul Brett <pa...@twopensource.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/
-----------------------------------------------------------

(Updated March 31, 2015, 11:11 p.m.)


Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.


Bugs: mesos-2332
    https://issues.apache.org/jira/browse/mesos-2332


Repository: mesos


Description
-------

Pull the common container definitions out of PortIsolatorMappingTest for reuse.


Diffs
-----

  src/tests/port_mapping_tests.cpp f4124c3 

Diff: https://reviews.apache.org/r/32659/diff/


Testing
-------

make check


Thanks,

Paul Brett


Re: Review Request 32659: Pull the common container definitions out of PortIsolatorMappingTest for reuse.

Posted by Paul Brett <pa...@twopensource.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32659/
-----------------------------------------------------------

(Updated March 31, 2015, 11:08 p.m.)


Review request for mesos, Chi Zhang, Ian Downes, and Cong Wang.


Bugs: mesos-2332
    https://issues.apache.org/jira/browse/mesos-2332


Repository: mesos


Description
-------

Pull the common container definitions out of PortIsolatorMappingTest for reuse.


Diffs
-----

  src/tests/port_mapping_tests.cpp f4124c3 

Diff: https://reviews.apache.org/r/32659/diff/


Testing
-------

make check


Thanks,

Paul Brett