You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@kudu.apache.org by "Dan Burkert (Code Review)" <ge...@cloudera.org> on 2017/01/21 04:47:58 UTC

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Hello Adar Dembo, Todd Lipcon, Alexey Serbin,

I'd like you to do a code review.  Please visit

    http://gerrit.cloudera.org:8080/5759

to review the following change.

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................

TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation

This rename is in anticipation of a major refactor to both of these
classes which will make them less specific to SASL. The file rename is
kept in a separate commit in order to preserve git history.

Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
---
M src/kudu/rpc/CMakeLists.txt
R src/kudu/rpc/client_negotiation.cc
R src/kudu/rpc/client_negotiation.h
M src/kudu/rpc/connection.cc
M src/kudu/rpc/connection.h
R src/kudu/rpc/negotiation-test.cc
M src/kudu/rpc/negotiation.cc
M src/kudu/rpc/reactor.cc
R src/kudu/rpc/server_negotiation.cc
R src/kudu/rpc/server_negotiation.h
10 files changed, 17 insertions(+), 17 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/59/5759/1
-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Todd Lipcon (Code Review)" <ge...@cloudera.org>.
Todd Lipcon has posted comments on this change.

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................


Patch Set 4: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Dan Burkert (Code Review)" <ge...@cloudera.org>.
Dan Burkert has uploaded a new patch set (#2).

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................

TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation

This rename is in anticipation of a major refactor to both of these
classes which will make them less specific to SASL. The file rename is
kept in a separate commit in order to preserve git history.

Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
---
M src/kudu/rpc/CMakeLists.txt
R src/kudu/rpc/client_negotiation.cc
R src/kudu/rpc/client_negotiation.h
M src/kudu/rpc/connection.cc
M src/kudu/rpc/connection.h
R src/kudu/rpc/negotiation-test.cc
M src/kudu/rpc/negotiation.cc
M src/kudu/rpc/reactor.cc
R src/kudu/rpc/server_negotiation.cc
R src/kudu/rpc/server_negotiation.h
10 files changed, 25 insertions(+), 24 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/59/5759/2
-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 2
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Dan Burkert (Code Review)" <ge...@cloudera.org>.
Hello Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/5759

to look at the new patch set (#3).

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................

TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation

This rename is in anticipation of a major refactor to both of these
classes which will make them less specific to SASL. The file rename is
kept in a separate commit in order to preserve git history.

Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
---
M src/kudu/rpc/CMakeLists.txt
R src/kudu/rpc/client_negotiation.cc
R src/kudu/rpc/client_negotiation.h
M src/kudu/rpc/connection.cc
M src/kudu/rpc/connection.h
R src/kudu/rpc/negotiation-test.cc
M src/kudu/rpc/negotiation.cc
M src/kudu/rpc/reactor.cc
R src/kudu/rpc/server_negotiation.cc
R src/kudu/rpc/server_negotiation.h
10 files changed, 27 insertions(+), 26 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/59/5759/3
-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Todd Lipcon (Code Review)" <ge...@cloudera.org>.
Todd Lipcon has posted comments on this change.

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................


Patch Set 3: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Dan Burkert (Code Review)" <ge...@cloudera.org>.
Hello Todd Lipcon, Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/5759

to look at the new patch set (#4).

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................

TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation

This rename is in anticipation of a major refactor to both of these
classes which will make them less specific to SASL. The file rename is
kept in a separate commit in order to preserve git history.

Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
---
M src/kudu/rpc/CMakeLists.txt
R src/kudu/rpc/client_negotiation.cc
R src/kudu/rpc/client_negotiation.h
M src/kudu/rpc/connection.cc
M src/kudu/rpc/connection.h
R src/kudu/rpc/negotiation-test.cc
M src/kudu/rpc/negotiation.cc
M src/kudu/rpc/reactor.cc
R src/kudu/rpc/server_negotiation.cc
R src/kudu/rpc/server_negotiation.h
10 files changed, 27 insertions(+), 26 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/59/5759/4
-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Dan Burkert (Code Review)" <ge...@cloudera.org>.
Dan Burkert has posted comments on this change.

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................


Patch Set 3:

(9 comments)

http://gerrit.cloudera.org:8080/#/c/5759/1/src/kudu/rpc/client_negotiation.cc
File src/kudu/rpc/client_negotiation.cc:

Line 151:   // TODO(unknown): Support security flags.
> warning: missing username/bug in TODO [google-readability-todo]
Done


Line 190:   }
> warning: don't use else after return [readability-else-after-return]
Done


Line 466:   switch (id) {
> warning: missing username/bug in TODO [google-readability-todo]
Done


Line 508:       (*psecret)->len = len;
> warning: either cast from 'int' to 'size_t' (aka 'unsigned long') is ineffe
Done


http://gerrit.cloudera.org:8080/#/c/5759/2/src/kudu/rpc/client_negotiation.cc
File src/kudu/rpc/client_negotiation.cc:

Line 509:       memcpy((*psecret)->data, plain_pass_.c_str(), len + 1);
> warning: either cast from 'int' to 'size_t' (aka 'unsigned long') is ineffe
Done


http://gerrit.cloudera.org:8080/#/c/5759/2/src/kudu/rpc/client_negotiation.h
File src/kudu/rpc/client_negotiation.h:

Line 32: #include "kudu/util/net/socket.h"
> warning: #includes are not sorted properly [llvm-include-order]
Done


http://gerrit.cloudera.org:8080/#/c/5759/1/src/kudu/rpc/server_negotiation.cc
File src/kudu/rpc/server_negotiation.cc:

Line 118:   // TODO(unknown): Support security flags.
> warning: missing username/bug in TODO [google-readability-todo]
Done


Line 162:   }
> warning: don't use else after return [readability-else-after-return]
Done


http://gerrit.cloudera.org:8080/#/c/5759/1/src/kudu/rpc/server_negotiation.h
File src/kudu/rpc/server_negotiation.h:

Line 30: #include "kudu/util/monotime.h"
> warning: #includes are not sorted properly [llvm-include-order]
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: Yes

[kudu-CR] TLS-negotiation [5/n]: Rename sasl [client|server] to [client|server] negotiation

Posted by "Todd Lipcon (Code Review)" <ge...@cloudera.org>.
Todd Lipcon has submitted this change and it was merged.

Change subject: TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation
......................................................................


TLS-negotiation [5/n]: Rename sasl_[client|server] to [client|server]_negotiation

This rename is in anticipation of a major refactor to both of these
classes which will make them less specific to SASL. The file rename is
kept in a separate commit in order to preserve git history.

Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Reviewed-on: http://gerrit.cloudera.org:8080/5759
Tested-by: Kudu Jenkins
Reviewed-by: Todd Lipcon <to...@apache.org>
---
M src/kudu/rpc/CMakeLists.txt
R src/kudu/rpc/client_negotiation.cc
R src/kudu/rpc/client_negotiation.h
M src/kudu/rpc/connection.cc
M src/kudu/rpc/connection.h
R src/kudu/rpc/negotiation-test.cc
M src/kudu/rpc/negotiation.cc
M src/kudu/rpc/reactor.cc
R src/kudu/rpc/server_negotiation.cc
R src/kudu/rpc/server_negotiation.h
10 files changed, 27 insertions(+), 26 deletions(-)

Approvals:
  Todd Lipcon: Looks good to me, approved
  Kudu Jenkins: Verified



-- 
To view, visit http://gerrit.cloudera.org:8080/5759
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ib4fb4bcdb7c7a43eea88b2911d2b2e75eafa62b0
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <da...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>