You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Tzu-Li (Gordon) Tai (Jira)" <ji...@apache.org> on 2020/03/04 12:15:00 UTC
[jira] [Closed] (FLINK-16398) Rename Protobuf Kafka Ingress /
Routable Kafka Ingress type identifier strings
[ https://issues.apache.org/jira/browse/FLINK-16398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Tzu-Li (Gordon) Tai closed FLINK-16398.
---------------------------------------
Fix Version/s: statefun-1.1
Resolution: Fixed
Merged for master via 11aceffacd6f878a922b6c0181e3ad055ce69a95
> Rename Protobuf Kafka Ingress / Routable Kafka Ingress type identifier strings
> ------------------------------------------------------------------------------
>
> Key: FLINK-16398
> URL: https://issues.apache.org/jira/browse/FLINK-16398
> Project: Flink
> Issue Type: Improvement
> Components: Stateful Functions
> Affects Versions: statefun-1.1
> Reporter: Tzu-Li (Gordon) Tai
> Assignee: Tzu-Li (Gordon) Tai
> Priority: Blocker
> Labels: pull-request-available
> Fix For: statefun-1.1
>
> Time Spent: 20m
> Remaining Estimate: 0h
>
> Currently the strings for the ingress type identifier for the (Routable) Kafka ingresses are:
> {{org.apache.flink.statefun.sdk.kafka/(routable-)protobuf-kafka-connector}}
> The term {{connector}} is better renamed as "ingress", to be consistent with Stateful Functions terminology.
> Also, we could maybe consider shortening the namespace string ({{org.apache.flink.statefun.sdk.kafka}}) to something more compact.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)