You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@apache.org by Andrea Cosentino <ac...@apache.org> on 2024/02/19 13:34:45 UTC
https://camel.apache.org/security/CVE-2024-23114.html: CVE-2024-23114: Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository
Severity: important
Affected versions:
- Apache Camel 3.0.0 before 3.21.4
- Apache Camel 3.22.0 before 3.22.1
- Apache Camel 4.0.0 before 4.0.4
- Apache Camel 4.1.0 before 4.4.0
Description:
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
This issue is being tracked as CAMEL-20306
Credit:
Federico Mariani From Apache Software Foundation (finder)
Andrea Cosentino from Apache Software Foundation (finder)
References:
https://camel.apache.org/
https://www.cve.org/CVERecord?id=CVE-2024-23114
https://issues.apache.org/jira/browse/CAMEL-20306