You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@oozie.apache.org by zhang junfan <zu...@gmail.com> on 2018/11/28 11:56:54 UTC

Review Request 69469: OOZIE-3393: Add Oozie instrumentation delayed metric in CoordMaterializeTriggerService

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69469/
-----------------------------------------------------------

Review request for oozie and András Piros.


Repository: oozie-git


Description
-------

We have multiple Oozie scheduled clusters. The problem that is currently encountered is that some materialize queues are too late to process during the peak hours of the scheduled tasks. We need to get the metrics of the delay queue for alarm monitoring and adjust the configuration to optimize.
Currently we have added metrics for queue size and latency in Oozie CoordMaterializeTriggerService class, in order to reflect the general trend of current scheduling.


Diffs
-----

  core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java 1cbd4749 


Diff: https://reviews.apache.org/r/69469/diff/1/


Testing
-------


Thanks,

zhang junfan


Re: Review Request 69469: OOZIE-3393: Add Oozie instrumentation delayed metric in CoordMaterializeTriggerService

Posted by zhang junfan <zu...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69469/
-----------------------------------------------------------

(Updated 四月 15, 2019, 8:18 a.m.)


Review request for oozie and András Piros.


Repository: oozie-git


Description
-------

We have multiple Oozie scheduled clusters. The problem that is currently encountered is that some materialize queues are too late to process during the peak hours of the scheduled tasks. We need to get the metrics of the delay queue for alarm monitoring and adjust the configuration to optimize.
Currently we have added metrics for queue size and latency in Oozie CoordMaterializeTriggerService class, in order to reflect the general trend of current scheduling.


Diffs (updated)
-----

  core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java 1cbd4749 
  core/src/test/java/org/apache/oozie/service/TestCoordMaterializeTriggerService.java e5acce69 


Diff: https://reviews.apache.org/r/69469/diff/3/

Changes: https://reviews.apache.org/r/69469/diff/2-3/


Testing
-------


Thanks,

zhang junfan


Re: Review Request 69469: OOZIE-3393: Add Oozie instrumentation delayed metric in CoordMaterializeTriggerService

Posted by zhang junfan <zu...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69469/
-----------------------------------------------------------

(Updated 十二月 5, 2018, 3:57 p.m.)


Review request for oozie and András Piros.


Repository: oozie-git


Description
-------

We have multiple Oozie scheduled clusters. The problem that is currently encountered is that some materialize queues are too late to process during the peak hours of the scheduled tasks. We need to get the metrics of the delay queue for alarm monitoring and adjust the configuration to optimize.
Currently we have added metrics for queue size and latency in Oozie CoordMaterializeTriggerService class, in order to reflect the general trend of current scheduling.


Diffs (updated)
-----

  core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java 1cbd4749 


Diff: https://reviews.apache.org/r/69469/diff/2/

Changes: https://reviews.apache.org/r/69469/diff/1-2/


Testing
-------


Thanks,

zhang junfan


Re: Review Request 69469: OOZIE-3393: Add Oozie instrumentation delayed metric in CoordMaterializeTriggerService

Posted by András Piros via Review Board <no...@reviews.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69469/#review210927
-----------------------------------------------------------



Overall direction is OK. Please add some unit tests, and sample `oozie-instrumentation.log` snippets.


core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java
Lines 71 (patched)
<https://reviews.apache.org/r/69469/#comment295765>

    `currentMaterializedJobsCount` would be a better name.



core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java
Lines 72 (patched)
<https://reviews.apache.org/r/69469/#comment295766>

    `currentMaterializedDelayedJobsCount` would be a better name.



core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java
Lines 174 (patched)
<https://reviews.apache.org/r/69469/#comment295763>

    Typo in variable name. What about instead: `final long now = ...`


- András Piros


On Nov. 28, 2018, 11:56 a.m., zhang junfan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/69469/
> -----------------------------------------------------------
> 
> (Updated Nov. 28, 2018, 11:56 a.m.)
> 
> 
> Review request for oozie and András Piros.
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> We have multiple Oozie scheduled clusters. The problem that is currently encountered is that some materialize queues are too late to process during the peak hours of the scheduled tasks. We need to get the metrics of the delay queue for alarm monitoring and adjust the configuration to optimize.
> Currently we have added metrics for queue size and latency in Oozie CoordMaterializeTriggerService class, in order to reflect the general trend of current scheduling.
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/service/CoordMaterializeTriggerService.java 1cbd4749 
> 
> 
> Diff: https://reviews.apache.org/r/69469/diff/1/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> zhang junfan
> 
>