You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by Jacques Le Roux <ja...@les7arts.com> on 2009/08/18 11:51:22 UTC

Re: Disappointment not to see any reply - [ Was - Re: svn commit: r791389 - in /ofbiz/trunk/specialpurpose/projectmgr: webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy widget/forms/ProjectForms.xml ]

Hi Hans, Ashish,

I doubt anybody will be against Ashish suggestions. So I take these advices in a general manner, and will try on my side to keep 
them in mind. On the other hand if it's the only changes needed why not make them yourself Ashish, if Hans don't care ?

Thanks

Jacques

From: "Ashish Vijaywargiya" <vi...@gmail.com>
> Hello Hans,
>
> I was expecting some reply from you on my email.
> It is very disappointing that you haven't updated your code in last 2 days
> and don't even prefer to reply if someone is addressing issues in your code.
>
>
> This is not the first time when you have ignored or missed the comments. Its
> third time when you have ignored the comments on your work when I have
> addressed something. I am unable to understand what are you trying to do by
> doing so.
>
> In future someone can refer the code written by you and can do copy paste.
> This will help to increase the bad quality of code in OFBiz. Which should
> not be acceptable from anybody IMO. So why can't we address such issues in
> the initial phase of development.
>
> Suppose few guys are working with me and they can refer the same code and
> again do copy paste of that code. For a new developer starting his / her
> carrier in OFBiz (or in some other project) it is very difficult to remember
> things that we call Best Practices in a day or so. In general what they do?
> they consider the code written in OFBiz as the "Ideal" code for further
> improvement / enhancement. So as a committer its our responsibility to
> provide the good quality of code that could be easily digestable for new or
> an experienced developer. Here I am not asking to provide the code that is
> 100% compliant but atleast we can try to achieve that level.
>
> Mistakes are done by human beings and I also do some mistakes in my commits.
>
> If someone have objections in my code then its my responsibility to reply
> and see what best suites for the community. And this is what I do and expect
> the same from everybody.
>
> I hope you should take my words positively, the main goal by writing this
> email is that we all as a committer are committed to provide best quality of
> code(Technical as well as functional) on which community and ourselves could
> feel proud. This is our job to do something "Good" and we should try to meet
> its expectations.
>
> Thanks!
> --
> Ashish
>
>
> On Mon, Jul 6, 2009 at 5:33 PM, Ashish Vijaywargiya <
> vijaywargiya.ashish@gmail.com> wrote:
>
>> Hello Hans,
>>
>> Isn't it good to use some verbose name for variables?
>>
>> For ex: The following statement:
>> + <entity-and entity-name="WorkEffortPartyAssignment" list="assigns"
>> filter-by-date="true">
>>
>> can be changed to
>>
>>  + <entity-and entity-name="WorkEffortPartyAssignment"
>> list="workEffortPartyAssignments" filter-by-date="true">
>>
>> or
>>
>>  + <entity-and entity-name="WorkEffortPartyAssignment"
>> list="workEffortPartyAssignmentList" filter-by-date="true">
>>
>> or if you want to keep your list name client specific then you can use:
>>
>>  + <entity-and entity-name="WorkEffortPartyAssignment"
>> list="workEffortPartyAssignmentClients" filter-by-date="true">
>>
>>
>> Another issue is with your another condition:
>> +            <entity-and entity-name="WorkEffortPartyAssignment"
>> list="assignsOrg" filter-by-date="true">
>>
>> Is "assignsOrg" good name for a list?
>> Please refer above options for its name.
>>
>> Please try to use more verbose variable name as this will help to see
>> consistent and good quality code from the community member if someone is
>> adding new feature around your work. And if they do copy paste then we will
>> be fine if consistent and good quality code is available in advance for
>> them.
>>
>> --
>> Ashish
>>
>>
>>
>> On Mon, Jul 6, 2009 at 11:30 AM, <ha...@apache.org> wrote:
>>
>>> Author: hansbak
>>> Date: Mon Jul  6 06:00:54 2009
>>> New Revision: 791389
>>>
>>> URL: http://svn.apache.org/viewvc?rev=791389&view=rev
>>> Log:
>>> edit project did not show the client billing partyId, also do not show
>>> nonbilled hours when either billing partyId or organization party is missing
>>>
>>> Modified:
>>>
>>>  ofbiz/trunk/specialpurpose/projectmgr/webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy
>>>    ofbiz/trunk/specialpurpose/projectmgr/widget/forms/ProjectForms.xml
>>>
>>> Modified:
>>> ofbiz/trunk/specialpurpose/projectmgr/webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy
>>> URL:
>>> http://svn.apache.org/viewvc/ofbiz/trunk/specialpurpose/projectmgr/webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy?rev=791389&r1=791388&r2=791389&view=diff
>>>
>>> ==============================================================================
>>> ---
>>> ofbiz/trunk/specialpurpose/projectmgr/webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy
>>> (original)
>>> +++
>>> ofbiz/trunk/specialpurpose/projectmgr/webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy
>>> Mon Jul  6 06:00:54 2009
>>> @@ -33,7 +33,9 @@
>>>        }
>>>        if (fromPartyId && toPartyId && fromPartyId.equals(toPartyId)) {
>>>                context.isBillable = false;
>>> -       } else {
>>> +       } else if (!toPartyId || !fromPartyId){
>>> +        context.isBillable = false;
>>> +       } else {
>>>                context.isBillable = true;
>>>        }
>>>  }
>>>
>>> Modified:
>>> ofbiz/trunk/specialpurpose/projectmgr/widget/forms/ProjectForms.xml
>>> URL:
>>> http://svn.apache.org/viewvc/ofbiz/trunk/specialpurpose/projectmgr/widget/forms/ProjectForms.xml?rev=791389&r1=791388&r2=791389&view=diff
>>>
>>> ==============================================================================
>>> --- ofbiz/trunk/specialpurpose/projectmgr/widget/forms/ProjectForms.xml
>>> (original)
>>> +++ ofbiz/trunk/specialpurpose/projectmgr/widget/forms/ProjectForms.xml
>>> Mon Jul  6 06:00:54 2009
>>> @@ -25,6 +25,16 @@
>>>             <entity-one entity-name="PartyGroup" value-field="partyGroup">
>>>                 <field-map field-name="partyId" from-field="partyId"/>
>>>             </entity-one>
>>> +            <entity-and entity-name="WorkEffortPartyAssignment"
>>> list="assigns" filter-by-date="true">
>>> +                <field-map field-name="workEffortId"
>>> from-field="parameters.projectId"/>
>>> +                <field-map field-name="roleTypeId"
>>> value="CLIENT_BILLING"/>
>>> +            </entity-and>
>>> +            <set field="project.clientBillingPartyId"
>>> from-field="assigns[0].partyId"/>
>>> +            <entity-and entity-name="WorkEffortPartyAssignment"
>>> list="assignsOrg" filter-by-date="true">
>>> +                <field-map field-name="workEffortId"
>>> from-field="parameters.projectId"/>
>>> +                <field-map field-name="roleTypeId"
>>> value="INTERNAL_ORGANIZATIO"/>
>>> +            </entity-and>
>>> +            <set field="project.organizationPartyId"
>>> from-field="assignsOrg[0].partyId"/>
>>>         </actions>
>>>         <alt-target use-when="project==null" target="createProject"/>
>>>         <field use-when="project==null" name="templateId">
>>>
>>>
>>>
>>
> 



Re: Disappointment not to see any reply - [ Was - Re: svn commit: r791389 - in /ofbiz/trunk/specialpurpose/projectmgr: webapp/projectmgr/WEB-INF/actions/ProjectIsBillable.groovy widget/forms/ProjectForms.xml ]

Posted by Ashish Vijaywargiya <vi...@gmail.com>.
I can do the changes  - will take care of it in a day or so.
The main question that comes in my mind is how many times I should do such
improvements ;o) ?

Anyway thanks Jacques for your comment here - It helps.

--
Ashish

On Tue, Aug 18, 2009 at 3:21 PM, Jacques Le Roux <
jacques.le.roux@les7arts.com> wrote:

> Hi Hans, Ashish,
>
> I doubt anybody will be against Ashish suggestions. So I take these advices
> in a general manner, and will try on my side to keep them in mind. On the
> other hand if it's the only changes needed why not make them yourself
> Ashish, if Hans don't care ?
>
> Thanks
>
> Jacques
>
> From: "Ashish Vijaywargiya" <vi...@gmail.com>
>
>