You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2018/04/24 14:07:17 UTC

httpcomponents-core git commit: Improve HeaderValueParser API doc (HTTPCORE-523) [Forced Update!]

Repository: httpcomponents-core
Updated Branches:
  refs/heads/4.4.x 1080d0931 -> fb0fda7d3 (forced update)


Improve HeaderValueParser API doc (HTTPCORE-523)


Project: http://git-wip-us.apache.org/repos/asf/httpcomponents-core/repo
Commit: http://git-wip-us.apache.org/repos/asf/httpcomponents-core/commit/fb0fda7d
Tree: http://git-wip-us.apache.org/repos/asf/httpcomponents-core/tree/fb0fda7d
Diff: http://git-wip-us.apache.org/repos/asf/httpcomponents-core/diff/fb0fda7d

Branch: refs/heads/4.4.x
Commit: fb0fda7d30bb34dc20ff2a173e615527e66970da
Parents: 5b4eef2
Author: Julian Reschke <ju...@gmx.de>
Authored: Tue Apr 24 11:07:40 2018 +0000
Committer: Oleg Kalnichevski <ol...@apache.org>
Committed: Tue Apr 24 16:06:52 2018 +0200

----------------------------------------------------------------------
 .../main/java/org/apache/http/message/HeaderValueParser.java   | 6 ++++++
 1 file changed, 6 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/httpcomponents-core/blob/fb0fda7d/httpcore/src/main/java/org/apache/http/message/HeaderValueParser.java
----------------------------------------------------------------------
diff --git a/httpcore/src/main/java/org/apache/http/message/HeaderValueParser.java b/httpcore/src/main/java/org/apache/http/message/HeaderValueParser.java
index 180f38f..8917f6f 100644
--- a/httpcore/src/main/java/org/apache/http/message/HeaderValueParser.java
+++ b/httpcore/src/main/java/org/apache/http/message/HeaderValueParser.java
@@ -68,6 +68,12 @@ public interface HeaderValueParser {
      * element or param will be stored as the empty {@link String};
      * if the "=" is also missing <var>null</var> will be stored instead.
      * </p>
+     * <p>
+     * Note that this parser does not apply to list-typed HTTP header fields in
+     * general; it is only suitable for fields that use the syntax described
+     * above. Counter-examples are "Link" (RFC 8288), "If-None-Match" (RFC 7232)
+     * or "Dav" (RFC 4918).
+     * </p>
      *
      * @param buffer    buffer holding the header value to parse
      * @param cursor    the parser cursor containing the current position and