You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Till Rohrmann (JIRA)" <ji...@apache.org> on 2017/06/29 12:22:00 UTC

[jira] [Updated] (FLINK-4344) Implement new JobManager

     [ https://issues.apache.org/jira/browse/FLINK-4344?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Till Rohrmann updated FLINK-4344:
---------------------------------
    Labels: flip-6  (was: )

> Implement new JobManager
> ------------------------
>
>                 Key: FLINK-4344
>                 URL: https://issues.apache.org/jira/browse/FLINK-4344
>             Project: Flink
>          Issue Type: New Feature
>          Components: Cluster Management
>            Reporter: Stephan Ewen
>              Labels: flip-6
>
> This is the parent issue for the efforts to implement the {{JobManager}} changes based on FLIP-6 (https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=65147077)
> Because of the breadth of changes, we should implement a new version of the {{JobManager}} (let's call it {{JobMaster}}) rather than updating the current {{JobManager}}. That will allow us to keep a working master branch.
> At the point when the new cluster management is on par with the current implementation, we will drop the old {{JobManager}} and rename the {{JobMaster}} to {{JobManager}}.
> Here is a sketch about the new design of the JobManager.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)