You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2018/08/10 16:55:00 UTC
[jira] [Commented] (GEODE-5555) Create `devBuild` build target for
typical developer workflow
[ https://issues.apache.org/jira/browse/GEODE-5555?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16576561#comment-16576561 ]
ASF subversion and git services commented on GEODE-5555:
--------------------------------------------------------
Commit e73ef5a2a0112255ccaa3acf949a1c4fc9548bc6 in geode's branch refs/heads/develop from [~rhoughton]
[ https://gitbox.apache.org/repos/asf?p=geode.git;h=e73ef5a ]
GEODE-5555: Add 'devBuild' task (#2293)
* devBuild depends on :assembly and :spotlessApply
* Ensure that spotlessApply and spotlessCheck run before compilation
*** This ordering dependency is project wide, not only with respect to
devBuild
* Correct apparent error in precheckin task only running
acceptanceTest task in geode-assembly module
*** Historically, this was the only module that contained
acceptanceTests. This was changed with the introduction of nebula
facets.
* Minor readability improvements in touched files.
Co-authored-by: Robert Houghton <rh...@pivotal.io>
Co-authored-by: Patrick Rhomberg <pr...@pivotal.io>
> Create `devBuild` build target for typical developer workflow
> -------------------------------------------------------------
>
> Key: GEODE-5555
> URL: https://issues.apache.org/jira/browse/GEODE-5555
> Project: Geode
> Issue Type: Improvement
> Components: build
> Reporter: Patrick Rhomberg
> Assignee: Patrick Rhomberg
> Priority: Major
> Labels: pull-request-available
> Time Spent: 50m
> Remaining Estimate: 0h
>
> A typical developer does not want to run, for instance, {{rat}} or {{javadoc}} as part of their standard build workflow. A {{devBuild}} target should only build classes and, likely, also include {{spotlessApply}}.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)