You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@apache.org by Francesco Chicchiriccò <il...@apache.org> on 2026/05/25 12:33:19 UTC
CVE-2026-42797: Apache Syncope: JexlContextBuilder Information Disclosure
Severity: moderate
Affected versions:
- Apache Syncope (org.apache.syncope.core:syncope-core-provisioning-api) 3.0 through 3.0.16
- Apache Syncope (org.apache.syncope.core:syncope-core-provisioning-api) 4.0 through 4.0.5
- Apache Syncope (org.apache.syncope.core:syncope-core-provisioning-api) 4.1 through 4.1.0
Description:
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.
An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Credit:
elin kai (finder)
References:
https://syncope.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-42797