You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Sandeep Singh (JIRA)" <ji...@apache.org> on 2016/05/12 15:56:13 UTC
[jira] [Created] (SPARK-15296) Refactor All Java Tests that use
SparkSession
Sandeep Singh created SPARK-15296:
-------------------------------------
Summary: Refactor All Java Tests that use SparkSession
Key: SPARK-15296
URL: https://issues.apache.org/jira/browse/SPARK-15296
Project: Spark
Issue Type: Improvement
Components: ML, MLlib, SQL, Tests
Reporter: Sandeep Singh
Priority: Minor
There's a lot of Duplicate code in Java tests. {{setUp()}} and {{tearDown()}} of most java test classes in SQL,ML,MLLib.
So will create a {{TestSparkSession}} class that has common code for {{setUp}} and {{tearDown}} and other classes just extend that class.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org