You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@gobblin.apache.org by "Urmi Mustafi (Jira)" <ji...@apache.org> on 2023/08/24 23:55:00 UTC
[jira] [Created] (GOBBLIN-1887) Increase Encapsulation in FlowTriggerHandler & Add Unit Tests
Urmi Mustafi created GOBBLIN-1887:
-------------------------------------
Summary: Increase Encapsulation in FlowTriggerHandler & Add Unit Tests
Key: GOBBLIN-1887
URL: https://issues.apache.org/jira/browse/GOBBLIN-1887
Project: Apache Gobblin
Issue Type: Bug
Components: gobblin-service
Reporter: Urmi Mustafi
Assignee: Abhishek Tiwari
Increase abstraction and encapsulation in FlowTriggerHandler with minor refactoring to static helper functions. Unpack objects as late as possible to make {{scheduleReminderForEvent}} easier to read. Add unit tests for each of the static helper functions. Also ensure that the {{reminderJobKey}} is also used as the {{reminderTrigger's key}}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)