You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by "Dmitry Potapov (JIRA)" <ji...@apache.org> on 2014/07/03 19:04:34 UTC
[jira] [Created] (HTTPCORE-386) BasicHttpResponse and
BasicAsync(Response/Request)Producer should have proper .toString()
implementation
Dmitry Potapov created HTTPCORE-386:
---------------------------------------
Summary: BasicHttpResponse and BasicAsync(Response/Request)Producer should have proper .toString() implementation
Key: HTTPCORE-386
URL: https://issues.apache.org/jira/browse/HTTPCORE-386
Project: HttpComponents HttpCore
Issue Type: Improvement
Reporter: Dmitry Potapov
Priority: Trivial
Sometimes it is useful to print Response/Request producer info to log. Doing this every time by hands leads to code duplications and poor code quality.
My suggestion is to add proper .toString() implementation to AbstractHttpEntity, BasicHttpResponse, BasicAsyncResponseProducer and BasicAsyncRequestProducer.
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org