You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@zookeeper.apache.org by "Hadoop QA (JIRA)" <ji...@apache.org> on 2017/06/29 01:43:00 UTC
[jira] [Commented] (ZOOKEEPER-2825) 1. Remove unnecessary import;
2. `contains` instead of `indexOf > -1` for more readable; 3. Standardize
`StringBuilder#append` usage for CLI module
[ https://issues.apache.org/jira/browse/ZOOKEEPER-2825?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16067567#comment-16067567 ]
Hadoop QA commented on ZOOKEEPER-2825:
--------------------------------------
-1 overall. GitHub Pull Request Build
+1 @author. The patch does not contain any @author tags.
+0 tests included. The patch appears to be a documentation patch that doesn't require tests.
+1 javadoc. The javadoc tool did not generate any warning messages.
+1 javac. The applied patch does not increase the total number of javac compiler warnings.
+1 findbugs. The patch does not introduce any new Findbugs (version 3.0.1) warnings.
+1 release audit. The applied patch does not increase the total number of release audit warnings.
-1 core tests. The patch failed core unit tests.
+1 contrib tests. The patch passed contrib unit tests.
Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/834//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/834//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/834//console
This message is automatically generated.
> 1. Remove unnecessary import; 2. `contains` instead of `indexOf > -1` for more readable; 3. Standardize `StringBuilder#append` usage for CLI module
> ---------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: ZOOKEEPER-2825
> URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2825
> Project: ZooKeeper
> Issue Type: Improvement
> Components: java client
> Affects Versions: 3.5.3
> Reporter: Benedict Jin
> Assignee: Benedict Jin
> Fix For: 3.5.4, 3.6.0
>
> Original Estimate: 72h
> Remaining Estimate: 72h
>
> * Remove unncessnary import;
> * `contains` instead of `indexOf > -1` for more readable;
> * Standardize `StringBuilder#append` usage for CLI module
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)