You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@aurora.apache.org by Kevin Sweeney <ke...@apache.org> on 2015/08/28 00:11:48 UTC

Review Request 37859: Rename slave to agent in src/main/python.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/37859/
-----------------------------------------------------------

Review request for Aurora, Bill Farner and Zameer Manji.


Bugs: AURORA-1454 and AURORA-1455
    https://issues.apache.org/jira/browse/AURORA-1454
    https://issues.apache.org/jira/browse/AURORA-1455


Repository: aurora


Description
-------

Use "Mesos Agent" instead of "Mesos Slave" in src/main/python.

This changes the name in all places where the Python code controls the use of the name (comments, pydoc, private variable names). It doesn't change the reference in places it doesn't control (`clusters.json`, `api.thrift`, `mesos.proto`, and the `Executor` interface from `mesos.interface`).

For ease of review and confidence, I intend to change `src/test/python` in a follow-up review.


Diffs
-----

  src/main/python/apache/aurora/client/api/command_runner.py c7238e274e53138187c2fe6fe5f14b7ae5f43ba2 
  src/main/python/apache/aurora/client/base.py 487f8e73fa978b150f2e5b60e0f64c71ce783c12 
  src/main/python/apache/aurora/client/cli/task.py d1f2568ac0afdd95c65523fde41f0dd16670a7a8 
  src/main/python/apache/aurora/executor/aurora_executor.py 96d7a336deebc4c95405d237df0ee11e7e055aa2 
  src/main/python/apache/aurora/executor/bin/thermos_executor_main.py b3e8bf1e924999306e0b8a1314273b22c51028e7 
  src/main/python/apache/aurora/executor/common/announcer.py dda76f018f472d7d8228459eb89f4c5daf9df26d 
  src/main/python/apache/aurora/executor/common/executor_detector.py a07bfc34caa5f86153ace8184b061e253c39e92e 
  src/main/python/apache/aurora/executor/executor_base.py 1db97cc8c12752d4eca339a7680ba963a66ffbce 

Diff: https://reviews.apache.org/r/37859/diff/


Testing
-------


Thanks,

Kevin Sweeney


Re: Review Request 37859: Rename slave to agent in src/main/python.

Posted by Aurora ReviewBot <wf...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/37859/#review96781
-----------------------------------------------------------


Master (06ddaad) is red with this patch.
  ./build-support/jenkins/build.sh

                     ==================== FAILURES ====================
                     _______________ test_path_detector _______________
                     
                         def test_path_detector():
                           ROOTS = ('/var/lib/mesos1/slaves', '/var/lib/mesos2/slaves')
                           FAKE_ROOT = '/var/blah/blah'
                           FAKE_CHECKPOINT_DIR = 'ckpt'
                         
                           path1_symlink, path1, path2 = (
                     >         ExecutorDetector.path(Match(ROOTS[0], 'slave001', 'framework1', 'executor1', 'latest')),
                               ExecutorDetector.path(Match(ROOTS[0], 'slave001', 'framework1', 'executor1', 'asdf-ghjk')),
                               ExecutorDetector.path(Match(ROOTS[1], 'slave002', 'framework2', 'executor2', 'latest')),
                           )
                     
                     src/test/python/apache/aurora/executor/common/test_path_detector.py:38: 
                     _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
                     
                     cls = <class 'apache.aurora.executor.common.executor_detector.ExecutorDetector'>
                     result = <common.test_path_detector.Match object at 0x7f3edaa2b710>
                     
                         @classmethod
                         def path(cls, result):
                     >     return os.path.join(*cls.PATTERN) % result.groups()
                     E     KeyError: 'agent_id'
                     
                     /tmp/user/2395/tmp5m7nmj/apache/aurora/executor/common/executor_detector.py:76: KeyError
                      generated xml file: /home/jenkins/jenkins-slave/workspace/AuroraBot/dist/test-results/src.test.python.apache.aurora.executor.common.path_detector.xml 
                     ============ 1 failed in 0.05 seconds ============
                     src.test.python.apache.aurora.client.hooks.non_hooked_api                       .....   SUCCESS
                     src.test.python.apache.aurora.executor.common.path_detector                     .....   FAILURE
                     src.test.python.apache.thermos.cli.commands.commands                            .....   SUCCESS
                     src.test.python.apache.thermos.cli.common                                       .....   SUCCESS
                     src.test.python.apache.thermos.cli.main                                         .....   SUCCESS
                     src.test.python.apache.thermos.common.test_pathspec                             .....   SUCCESS
                     src.test.python.apache.thermos.monitoring.test_disk                             .....   SUCCESS
                     
FAILURE


               FAILURE


I will refresh this build result if you post a review containing "@ReviewBot retry"

- Aurora ReviewBot


On Aug. 27, 2015, 10:11 p.m., Kevin Sweeney wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/37859/
> -----------------------------------------------------------
> 
> (Updated Aug. 27, 2015, 10:11 p.m.)
> 
> 
> Review request for Aurora, Bill Farner and Zameer Manji.
> 
> 
> Bugs: AURORA-1454 and AURORA-1455
>     https://issues.apache.org/jira/browse/AURORA-1454
>     https://issues.apache.org/jira/browse/AURORA-1455
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Use "Mesos Agent" instead of "Mesos Slave" in src/main/python.
> 
> This changes the name in all places where the Python code controls the use of the name (comments, pydoc, private variable names). It doesn't change the reference in places it doesn't control (`clusters.json`, `api.thrift`, `mesos.proto`, and the `Executor` interface from `mesos.interface`).
> 
> For ease of review and confidence, I intend to change `src/test/python` in a follow-up review.
> 
> 
> Diffs
> -----
> 
>   src/main/python/apache/aurora/client/api/command_runner.py c7238e274e53138187c2fe6fe5f14b7ae5f43ba2 
>   src/main/python/apache/aurora/client/base.py 487f8e73fa978b150f2e5b60e0f64c71ce783c12 
>   src/main/python/apache/aurora/client/cli/task.py d1f2568ac0afdd95c65523fde41f0dd16670a7a8 
>   src/main/python/apache/aurora/executor/aurora_executor.py 96d7a336deebc4c95405d237df0ee11e7e055aa2 
>   src/main/python/apache/aurora/executor/bin/thermos_executor_main.py b3e8bf1e924999306e0b8a1314273b22c51028e7 
>   src/main/python/apache/aurora/executor/common/announcer.py dda76f018f472d7d8228459eb89f4c5daf9df26d 
>   src/main/python/apache/aurora/executor/common/executor_detector.py a07bfc34caa5f86153ace8184b061e253c39e92e 
>   src/main/python/apache/aurora/executor/executor_base.py 1db97cc8c12752d4eca339a7680ba963a66ffbce 
> 
> Diff: https://reviews.apache.org/r/37859/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Kevin Sweeney
> 
>