You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by Uwe Schindler <uw...@thetaphi.de> on 2016/12/09 23:25:27 UTC

RE: lucene-solr:master: LUCENE-7581: don't allow updating a doc values field if it's used in the index sort

Hi,

> +    this.indexSortFields = Arrays.stream(sort.getSort()).map((s) ->
> s.getField()).collect(Collectors.toSet());

I'd use method references instead of Lambdas:

Instead of: map((s) -> s.getField())
Use: map(s::getField)

This spares a synthetic lambda$xxx method that clutters stack trace and is more readable.

Uwe


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


RE: lucene-solr:master: LUCENE-7581: don't allow updating a doc values field if it's used in the index sort

Posted by Uwe Schindler <uw...@thetaphi.de>.
Hi,


> > +    this.indexSortFields = Arrays.stream(sort.getSort()).map((s) ->
> > s.getField()).collect(Collectors.toSet());
> 
> I'd use method references instead of Lambdas:
> 
> Instead of: map((s) -> s.getField())
> Use: map(s::getField)

Correction: map(SortField::getField)

> This spares a synthetic lambda$xxx method that clutters stack trace and is
> more readable.
> 
> Uwe
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Re: lucene-solr:master: LUCENE-7581: don't allow updating a doc values field if it's used in the index sort

Posted by Michael McCandless <lu...@mikemccandless.com>.
Thanks Uwe, I'll fix.

Mike McCandless

http://blog.mikemccandless.com


On Fri, Dec 9, 2016 at 6:25 PM, Uwe Schindler <uw...@thetaphi.de> wrote:
> Hi,
>
>> +    this.indexSortFields = Arrays.stream(sort.getSort()).map((s) ->
>> s.getField()).collect(Collectors.toSet());
>
> I'd use method references instead of Lambdas:
>
> Instead of: map((s) -> s.getField())
> Use: map(s::getField)
>
> This spares a synthetic lambda$xxx method that clutters stack trace and is more readable.
>
> Uwe
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org