You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@madlib.apache.org by "Frank McQuillan (JIRA)" <ji...@apache.org> on 2019/04/23 17:26:00 UTC

[jira] [Commented] (MADLIB-1315) Define the output of madlib_keras_predict

    [ https://issues.apache.org/jira/browse/MADLIB-1315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16824354#comment-16824354 ] 

Frank McQuillan commented on MADLIB-1315:
-----------------------------------------

madlib_keras.sql_in

{code}
CREATE OR REPLACE FUNCTION MADLIB_SCHEMA.madlib_keras_predict(
    model_table             VARCHAR,
    test_table              VARCHAR,
    id_col                  VARCHAR,
    independent_varname     VARCHAR,
    output_table            VARCHAR,
    pred_type               VARCHAR
{code}

> Define the output of madlib_keras_predict
> -----------------------------------------
>
>                 Key: MADLIB-1315
>                 URL: https://issues.apache.org/jira/browse/MADLIB-1315
>             Project: Apache MADlib
>          Issue Type: New Feature
>          Components: Deep Learning
>            Reporter: Nandish Jayaram
>            Priority: Major
>             Fix For: v1.16
>
>
> Currently, we only give class label as output in output table. The following output format can be more informative, following the output format in MLP (http://madlib.apache.org/docs/latest/group__grp__nn.html#predict).
> Requirements:
> 1. Update predict interface to have a new optional param named `pred_type`. It takes two values, `response` or `prob`, and default can be `response`.
> 1. If `pred_type=response`, create one output column for the predicted class label. Following the convention in MLP, this column is to be named `estimated_COL_NAME` where COL_NAME is the name of the column being predicted.
> 1. If `pred_type=prob`, create one output column for each distinct class value found in training data (this is captured in `class_values` column from model summary table). The new columns should be named `prob_CLASS` where CLASS is the corresponding class value.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)