You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@struts.apache.org by "Lukasz Lenart (JIRA)" <ji...@apache.org> on 2013/03/18 20:52:16 UTC

[jira] [Updated] (WW-4016) Rename validatorType to validatorName

     [ https://issues.apache.org/jira/browse/WW-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Lukasz Lenart updated WW-4016:
------------------------------

    Summary: Rename validatorType to validatorName  (was: Refactor validationType to be an Enum and not a String)
    
> Rename validatorType to validatorName
> -------------------------------------
>
>                 Key: WW-4016
>                 URL: https://issues.apache.org/jira/browse/WW-4016
>             Project: Struts 2
>          Issue Type: Sub-task
>          Components: XML Validators
>    Affects Versions: 2.3.12
>            Reporter: Lukasz Lenart
>            Priority: Minor
>             Fix For: 2.3.13
>
>
> Right no validatorType is a simple String in AnnotationValidationConfigurationBuilder which can lead to mistakes.
> {code:java}
> String validatorType = "regex";
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira