You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Elek, Marton (JIRA)" <ji...@apache.org> on 2018/09/18 06:34:00 UTC
[jira] [Commented] (HDDS-490) Improve om and scm start up options
[ https://issues.apache.org/jira/browse/HDDS-490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16618548#comment-16618548 ]
Elek, Marton commented on HDDS-490:
-----------------------------------
1. I would prefer to use the more GNU style --create-object-store. (no camel case)
2. Would be easier for me to use the same option for scm and om (--format could be a generic or --init. With picocli it could be a secondary alias.) scm --format / om --format
3. Please allow the run multiple times without exiting with exit code. It's very important for kubernetes + containerized word. (In kubernetes there is an option to define an init container. We can add 'ozone om --format' to it, but it should work at the second ran.) I propose to introduce a new argument, something like '--if-not-exists', and in that case error should not be thrown. You can suggest better name ('--if-missing' ?). By default it could be false and the default behaviour could be the failing (as described in 3).
> Improve om and scm start up options
> ------------------------------------
>
> Key: HDDS-490
> URL: https://issues.apache.org/jira/browse/HDDS-490
> Project: Hadoop Distributed Data Store
> Issue Type: Bug
> Reporter: Namit Maheshwari
> Assignee: Namit Maheshwari
> Priority: Major
> Labels: incompatible
>
> I propose the following changes:
> # Rename createObjectStore to format
> # Change the flag to use --createObjectStore instead of using -createObjectStore. It is also applicable to other scm and om startup options.
> # Fail to format existing object store. If a user runs:
> {code:java}
> ozone om -createObjectStore{code}
> And there is already an object store, it should give a warning message and exit the process.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org