You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@groovy.apache.org by MG <mg...@arscreat.com> on 2018/07/22 21:39:17 UTC

bool

Hi,

since things are going so well with my "fin" = "final" proposal, I 
propose that Groovy support "bool" as a shortcut for "boolean".

"boolean" is already seeing large scale use by Groovy developers, "bool" 
instead of "boolean" saves nearly half of the keyword's characters, 
"bool" is used in C++, it fits better with the also widely used "int", 
and Groovy 3.0 is the ideal opportunity to introduce such language 
extensions.

Cheers,
mg




Re: bool

Posted by Keith Suderman <ke...@vassar.edu>.
Sending this again because my mail program keeps insisting on changing the From: address... apologies if this gets double posted.

-1 on all proposals that introduce new reserved words that do not have a strong justification and use case.  The only thing `fin` and `bool` will do is potentially conflict with existing variable/method names in programs with little other benefit.  One of my biggest pet peeve's with Python is how they have polluted the namespace with short names I like to use as variable names (dict, list, etc).  Let's not do this with Groovy.

Just my two cents.
Keith

> On Jul 22, 2018, at 4:57 PM, Jennifer Strater <jenn.strater@gmail.com <ma...@gmail.com>> wrote:
> 
> Hi mg,
> 
> I also don't like the 'fin' proposal, but I could get behind 'bool'. It's shorter but doesn't lose the meaning. It also makes it easier for people coming from other programming languages.
> 
> Best,
> Jenn
>  <https://twitter.com/codejennerator>  <https://linkedin.com/in/jennstrater>
> 
> On Sun, Jul 22, 2018 at 11:39 PM, MG <mgbiz@arscreat.com <ma...@arscreat.com>> wrote:
> Hi,
> 
> since things are going so well with my "fin" = "final" proposal, I propose that Groovy support "bool" as a shortcut for "boolean".
> 
> "boolean" is already seeing large scale use by Groovy developers, "bool" instead of "boolean" saves nearly half of the keyword's characters, "bool" is used in C++, it fits better with the also widely used "int", and Groovy 3.0 is the ideal opportunity to introduce such language extensions.
> 
> Cheers,
> mg
> 
> 
> 
> 

----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu <ma...@cs.vassar.edu>






----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu





Re: bool

Posted by mg <mg...@arscreat.com>.
Same here ;-)
Wanted to reply all day, but didn't have the time:
Evidently I do think that introducing bool (or fin) is worth its cost, otherwise I would not go through the hassle of proposing and defending it here, knowing that the chances of acceptance are slim indeed.
As I've said before, the upcoming Groovy 3.0 makes this the time to propose these things. 
I think one should not reject a proposal simple on the basis that it might open the door for horrid things that come after it. Proposals are not a zombie horde, but each has to pass the gate on its own merit.
dicts/lists/... etc - are not fundamental typs, so they are not lowercase in Groovy, so I guess no fears there that someone might suggest them as keywords.
I prefer to express the list content in its name, ie persons or personList, or maybe pel if it is used a lot, but to each his own.
Using bool as a name for a boolean variable makes little sense to me, since bools basically cry out to express what true means in their name. So using bool as a name is close to using obj0, obj1, obj2, ... for all your variables to me...
Cheers,mg

-------- Ursprüngliche Nachricht --------Von: Jennifer Strater <je...@gmail.com> Datum: 23.07.18  23:15  (GMT+01:00) An: dev@groovy.apache.org Betreff: Re: bool 
Hi Keith,
Just FYI, I did get all 3 of your messages. 😂
Best,Jenn

On Mon, Jul 23, 2018 at 10:57 PM, Keith Suderman <ke...@vassar.edu> wrote:
And again, because apparently MacMail is MUCH smarter than I am...
Sending this again because my mail program keeps insisting on changing the From: address... apologies if this gets double posted.
-1 on all proposals that introduce new reserved words that do not have a strong justification and use case.  The only thing `fin` and `bool` will do is potentially conflict with existing variable/method names in programs with little other benefit.  One of my biggest pet peeve's with Python is how they have polluted the namespace with short names I like to use as variable names (dict, list, etc).  Let's not do this with Groovy.
Just my two cents.Keith

On Jul 22, 2018, at 4:57 PM, Jennifer Strater <je...@gmail.com> wrote:
Hi mg,
I also don't like the 'fin' proposal, but I could get behind 'bool'. It's shorter but doesn't lose the meaning. It also makes it easier for people coming from other programming languages.
Best,Jenn 


On Sun, Jul 22, 2018 at 11:39 PM, MG <mg...@arscreat.com> wrote:
Hi,



since things are going so well with my "fin" = "final" proposal, I propose that Groovy support "bool" as a shortcut for "boolean".



"boolean" is already seeing large scale use by Groovy developers, "bool" instead of "boolean" saves nearly half of the keyword's characters, "bool" is used in C++, it fits better with the also widely used "int", and Groovy 3.0 is the ideal opportunity to introduce such language extensions.



Cheers,

mg











----------------------Keith SudermanResearch AssociateDepartment of Computer ScienceVassar College, Poughkeepsie NYsuderman@cs.vassar.edu








----------------------Keith SudermanResearch AssociateDepartment of Computer ScienceVassar College, Poughkeepsie NYsuderman@cs.vassar.edu








Re: bool

Posted by Jennifer Strater <je...@gmail.com>.
Hi Keith,

Just FYI, I did get all 3 of your messages. 😂

Best,
Jenn

On Mon, Jul 23, 2018 at 10:57 PM, Keith Suderman <ke...@vassar.edu>
wrote:

> And again, because apparently MacMail is MUCH smarter than I am...
>
> Sending this again because my mail program keeps insisting on changing the
> From: address... apologies if this gets double posted.
>
> -1 on all proposals that introduce new reserved words that do not have a
> strong justification and use case.  The only thing `fin` and `bool` will do
> is potentially conflict with existing variable/method names in programs
> with little other benefit.  One of my biggest pet peeve's with Python is
> how they have polluted the namespace with short names I like to use as
> variable names (dict, list, etc).  Let's not do this with Groovy.
>
> Just my two cents.
> Keith
>
> On Jul 22, 2018, at 4:57 PM, Jennifer Strater <je...@gmail.com>
> wrote:
>
> Hi mg,
>
> I also don't like the 'fin' proposal, but I could get behind 'bool'. It's
> shorter but doesn't lose the meaning. It also makes it easier for people
> coming from other programming languages.
>
> Best,
> Jenn
> <https://twitter.com/codejennerator>
> <https://linkedin.com/in/jennstrater>
>
> On Sun, Jul 22, 2018 at 11:39 PM, MG <mg...@arscreat.com> wrote:
>
>> Hi,
>>
>> since things are going so well with my "fin" = "final" proposal, I
>> propose that Groovy support "bool" as a shortcut for "boolean".
>>
>> "boolean" is already seeing large scale use by Groovy developers, "bool"
>> instead of "boolean" saves nearly half of the keyword's characters, "bool"
>> is used in C++, it fits better with the also widely used "int", and Groovy
>> 3.0 is the ideal opportunity to introduce such language extensions.
>>
>> Cheers,
>> mg
>>
>>
>>
>>
>
> ----------------------
> Keith Suderman
> Research Associate
> Department of Computer Science
> Vassar College, Poughkeepsie NY
> suderman@cs.vassar.edu
>
>
>
>
>
>
> ----------------------
> Keith Suderman
> Research Associate
> Department of Computer Science
> Vassar College, Poughkeepsie NY
> suderman@cs.vassar.edu
>
>
>
>
>

Re: bool

Posted by Keith Suderman <ke...@vassar.edu>.
And again, because apparently MacMail is MUCH smarter than I am...

Sending this again because my mail program keeps insisting on changing the From: address... apologies if this gets double posted.

-1 on all proposals that introduce new reserved words that do not have a strong justification and use case.  The only thing `fin` and `bool` will do is potentially conflict with existing variable/method names in programs with little other benefit.  One of my biggest pet peeve's with Python is how they have polluted the namespace with short names I like to use as variable names (dict, list, etc).  Let's not do this with Groovy.

Just my two cents.
Keith

> On Jul 22, 2018, at 4:57 PM, Jennifer Strater <jenn.strater@gmail.com <ma...@gmail.com>> wrote:
> 
> Hi mg,
> 
> I also don't like the 'fin' proposal, but I could get behind 'bool'. It's shorter but doesn't lose the meaning. It also makes it easier for people coming from other programming languages.
> 
> Best,
> Jenn
>  <https://twitter.com/codejennerator>  <https://linkedin.com/in/jennstrater>
> 
> On Sun, Jul 22, 2018 at 11:39 PM, MG <mgbiz@arscreat.com <ma...@arscreat.com>> wrote:
> Hi,
> 
> since things are going so well with my "fin" = "final" proposal, I propose that Groovy support "bool" as a shortcut for "boolean".
> 
> "boolean" is already seeing large scale use by Groovy developers, "bool" instead of "boolean" saves nearly half of the keyword's characters, "bool" is used in C++, it fits better with the also widely used "int", and Groovy 3.0 is the ideal opportunity to introduce such language extensions.
> 
> Cheers,
> mg
> 
> 
> 
> 

----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu <ma...@cs.vassar.edu>






----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu <ma...@cs.vassar.edu>





Re: bool

Posted by Keith Suderman <ke...@vassar.edu>.
-1 on all proposals that introduce new keywords that do not have a strong justification and use case.  The only thing `fin` and `bool` will do is potentially conflict with existing variable/method names in programs with little other benefit.  One of my biggest pet peeve's with Python is how they have polluted the namespace with short names I typically use as variable names (dict, list, etc).  Let's not do this with Groovy.

Just my two cents.
Keith

> On Jul 22, 2018, at 4:57 PM, Jennifer Strater <je...@gmail.com> wrote:
> 
> Hi mg,
> 
> I also don't like the 'fin' proposal, but I could get behind 'bool'. It's shorter but doesn't lose the meaning. It also makes it easier for people coming from other programming languages.
> 
> Best,
> Jenn
>  <https://twitter.com/codejennerator>  <https://linkedin.com/in/jennstrater>
> 
> On Sun, Jul 22, 2018 at 11:39 PM, MG <mgbiz@arscreat.com <ma...@arscreat.com>> wrote:
> Hi,
> 
> since things are going so well with my "fin" = "final" proposal, I propose that Groovy support "bool" as a shortcut for "boolean".
> 
> "boolean" is already seeing large scale use by Groovy developers, "bool" instead of "boolean" saves nearly half of the keyword's characters, "bool" is used in C++, it fits better with the also widely used "int", and Groovy 3.0 is the ideal opportunity to introduce such language extensions.
> 
> Cheers,
> mg
> 
> 
> 
> 

----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu





Re: bool

Posted by mg <mg...@arscreat.com>.
Hi Jenn,
@bool: You are right "bool" is of course used by many languages, including Python :-)
@meaning of "fin": I was thinking of the French word for "end".
Cheers,mg

-------- Ursprüngliche Nachricht --------Von: Jennifer Strater <je...@gmail.com> Datum: 22.07.18  23:57  (GMT+01:00) An: dev@groovy.apache.org Betreff: Re: bool 
Hi mg,
I also don't like the 'fin' proposal, but I could get behind 'bool'. It's shorter but doesn't lose the meaning. It also makes it easier for people coming from other programming languages.
Best,Jenn 


On Sun, Jul 22, 2018 at 11:39 PM, MG <mg...@arscreat.com> wrote:
Hi,



since things are going so well with my "fin" = "final" proposal, I propose that Groovy support "bool" as a shortcut for "boolean".



"boolean" is already seeing large scale use by Groovy developers, "bool" instead of "boolean" saves nearly half of the keyword's characters, "bool" is used in C++, it fits better with the also widely used "int", and Groovy 3.0 is the ideal opportunity to introduce such language extensions.



Cheers,

mg










Re: bool

Posted by Jennifer Strater <je...@gmail.com>.
Hi mg,

I also don't like the 'fin' proposal, but I could get behind 'bool'. It's
shorter but doesn't lose the meaning. It also makes it easier for people
coming from other programming languages.

Best,
Jenn
<https://twitter.com/codejennerator>  <https://linkedin.com/in/jennstrater>

On Sun, Jul 22, 2018 at 11:39 PM, MG <mg...@arscreat.com> wrote:

> Hi,
>
> since things are going so well with my "fin" = "final" proposal, I propose
> that Groovy support "bool" as a shortcut for "boolean".
>
> "boolean" is already seeing large scale use by Groovy developers, "bool"
> instead of "boolean" saves nearly half of the keyword's characters, "bool"
> is used in C++, it fits better with the also widely used "int", and Groovy
> 3.0 is the ideal opportunity to introduce such language extensions.
>
> Cheers,
> mg
>
>
>
>

Re: bool

Posted by mg <mg...@arscreat.com>.
I wanted to keep my mail concise, but also aliasing Bool = Boolean was more or less implied, for consistency & brevity reasons.
I would also think that Java would introduce Int = Integer, or use int = Integer in that case...
-------- Ursprüngliche Nachricht --------Von: Russel Winder <ru...@winder.org.uk> Datum: 23.07.18  10:22  (GMT+01:00) An: dev@groovy.apache.org Betreff: Re: bool 
On Sun, 2018-07-22 at 23:39 +0200, MG wrote:
> Hi,
> 
> since things are going so well with my "fin" = "final" proposal, I 
> propose that Groovy support "bool" as a shortcut for "boolean".
> 
> "boolean" is already seeing large scale use by Groovy developers,
> "bool" 
> instead of "boolean" saves nearly half of the keyword's characters, 
> "bool" is used in C++, it fits better with the also widely used
> "int", 
> and Groovy 3.0 is the ideal opportunity to introduce such language 
> extensions.
> 

Isn't the long term intention to remove all primitive types from
languages compiling to the JVM?

Instead of int people are supposed to use Integer, instead of boolean
people are supposed to use Boolean, and leave all the optimisation to
the JVM.

Is there any point in fiddling with Groovy primitive type names in this
context?

-- 
Russel.
===========================================
Dr Russel Winder      t: +44 20 7585 2200
41 Buckmaster Road    m: +44 7770 465 077
London SW11 1EN, UK   w: www.russel.org.uk

Re: bool

Posted by Russel Winder <ru...@winder.org.uk>.
On Sun, 2018-07-22 at 23:39 +0200, MG wrote:
> Hi,
> 
> since things are going so well with my "fin" = "final" proposal, I 
> propose that Groovy support "bool" as a shortcut for "boolean".
> 
> "boolean" is already seeing large scale use by Groovy developers,
> "bool" 
> instead of "boolean" saves nearly half of the keyword's characters, 
> "bool" is used in C++, it fits better with the also widely used
> "int", 
> and Groovy 3.0 is the ideal opportunity to introduce such language 
> extensions.
> 

Isn't the long term intention to remove all primitive types from
languages compiling to the JVM?

Instead of int people are supposed to use Integer, instead of boolean
people are supposed to use Boolean, and leave all the optimisation to
the JVM.

Is there any point in fiddling with Groovy primitive type names in this
context?

-- 
Russel.
===========================================
Dr Russel Winder      t: +44 20 7585 2200
41 Buckmaster Road    m: +44 7770 465 077
London SW11 1EN, UK   w: www.russel.org.uk