You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "Kirk Lund (JIRA)" <ji...@apache.org> on 2019/01/10 20:55:00 UTC

[jira] [Created] (GEODE-6265) Rename TestingOnly annotation to VisibleForTesting

Kirk Lund created GEODE-6265:
--------------------------------

             Summary: Rename TestingOnly annotation to VisibleForTesting
                 Key: GEODE-6265
                 URL: https://issues.apache.org/jira/browse/GEODE-6265
             Project: Geode
          Issue Type: Wish
          Components: tests
            Reporter: Kirk Lund


This was discussed recently on the dev-list and we decided to rename our custom annotation TestingOnly which means that the annotated entity is visible only for testing. For example, a method might be package-private instead of private to allow unit tests to invoke it.

Guava and AssertJ both use a similar annotation called VisibleForTesting. The name is more descriptive and less ambiguous.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)