You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Greg Brown (JIRA)" <ji...@apache.org> on 2010/08/08 19:24:16 UTC

[jira] Resolved: (PIVOT-523) Rename Alert/Prompt getSelectedOption() to getSelectedOptionIndex()

     [ https://issues.apache.org/jira/browse/PIVOT-523?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Greg Brown resolved PIVOT-523.
------------------------------

    Resolution: Fixed

> Rename Alert/Prompt getSelectedOption() to getSelectedOptionIndex()
> -------------------------------------------------------------------
>
>                 Key: PIVOT-523
>                 URL: https://issues.apache.org/jira/browse/PIVOT-523
>             Project: Pivot
>          Issue Type: Improvement
>          Components: wtk
>            Reporter: Greg Brown
>            Priority: Minor
>             Fix For: 2.0
>
>
> The current method name implies that the option value will be returned, rather than the option index. Renaming the method will eliminate this ambiguity. A new getSelectedOption() method should be added that returns the actual option value.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.