You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Konrad Windszus (Jira)" <ji...@apache.org> on 2024/02/26 14:06:00 UTC

[jira] [Resolved] (MCOMPILER-577) Rename parameter "forceJavacCompilerUse"

     [ https://issues.apache.org/jira/browse/MCOMPILER-577?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Konrad Windszus resolved MCOMPILER-577.
---------------------------------------
    Resolution: Fixed

> Rename parameter "forceJavacCompilerUse"
> ----------------------------------------
>
>                 Key: MCOMPILER-577
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-577
>             Project: Maven Compiler Plugin
>          Issue Type: Improvement
>            Reporter: Konrad Windszus
>            Assignee: Konrad Windszus
>            Priority: Major
>             Fix For: next-release
>
>
> The name {{forceJavacCompilerUse}} (https://maven.apache.org/plugins/maven-compiler-plugin/compile-mojo.html#forceJavacCompilerUse) is confusing, because it only determines which API to use to access {{javac}}, but doesn't actually affect the compiler being used (which is determined via {{compilerId}} or toolchains).
> I would propose to rename that to {{forceLegacyJavacApi}} and clarify that this currently only has an effect on compiler {{javac}} (in case it is not forked). In order to be backwards-compatible the old name should still be considered as alias.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)