You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@roller.apache.org by Glen Mazza <gl...@gmail.com> on 2013/03/24 12:25:04 UTC

Rename RefererManager to ReferrerManager?

Hi, I'd like to implement 
https://issues.apache.org/jira/browse/ROL-1229, on at least 5.1 
(possibly 5.0.2 as well).  Any critical backwards compatibility problems 
if I do so?  Another alternative is to close this issue as a "Won't 
Fix".  (As "referer" is an HTTP term: 
http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer, 
misspelled or not.)

Thanks,
Glen


Re: Rename RefererManager to ReferrerManager?

Posted by Glen Mazza <gl...@gmail.com>.
I'm going to hold off on this change (for now at least) -- it's not just 
that four classes would need renaming (including TurnoverReferersTask, 
JPARefererManagerImpl, and RefererTest), there's "referer" member 
variables and accessor methods within those classes that would need 
updating, affecting roughly 25 other classes that call any of those four 
classes' methods, possibly more in the ORM files as the database table 
is called "Referer" still (which presumably, in order to be consistent, 
we should rename as well, bringing up lots of backward compatibility 
headaches.)

I'm also not fully persuaded of the validity of the change (even if it 
were simple to do) as "Referer" can be considered a proper noun given 
that it's defined in the HTTP specification and therefore can't be a 
misspelling.  If the HTTP specification called a referrer a "pumpkin" 
then we'd have an "PumpkinManager", "pumpkn" then a "PumpknManager", 
"xxxxx" then an "XxxxxManager", etc., none of which would be 
misspellings.  So we have "RefererManager".

Glen

On 03/24/2013 09:15 PM, Anil Gangolli wrote:
>
> Part of the origin of the problem is that the HTTP 1.0 Header has the 
> misspelling.  See
> http://en.wikipedia.org/wiki/HTTP_referer for the history.  I think I 
> made an effort long ago to correct it in our codebase where it was not 
> a direct reference to the header name, but we may have regressed.
>
> --a.
>
> On 3/24/13 8:09 AM, Dave wrote:
>> On Sun, Mar 24, 2013 at 9:51 AM, Glen Mazza <gl...@gmail.com> 
>> wrote:
>>
>>> I'll look at the source more thoroughly; we seem to be 50/50 between 
>>> the
>>> two spellings.  The *only* reason why I might want to apply it to 
>>> 5.0.2 is
>>> because this change affects several files and it makes it easier to
>>> backport *other* patches and security fixes when the underlying 
>>> files are
>>> identical.
>>>
>> Very good point.
>>
>> - Dave
>>
>>
>>
>>> On 03/24/2013 09:22 AM, Dave wrote:
>>>
>>>> I could go either way on this one, so if you want to take action 
>>>> please
>>>> decide and go ahead.
>>>>
>>>> However, I don't think we should address this in 5.0.x -- I think we
>>>> should
>>>> only address security issues and critical bugs there and a spelling 
>>>> error
>>>> does not feel like a critical bug.
>>>>
>>>> Thanks,
>>>> - Dave
>>>>
>>>>
>>>>
>>>> On Sun, Mar 24, 2013 at 7:25 AM, Glen Mazza <gl...@gmail.com> 
>>>> wrote:
>>>>
>>>>   Hi, I'd like to implement https://issues.apache.org/****
>>>>> jira/browse/ROL-1229 
>>>>> <https://issues.apache.org/**jira/browse/ROL-1229><
>>>>> https://**issues.apache.org/jira/browse/**ROL-1229<https://issues.apache.org/jira/browse/ROL-1229> 
>>>>>
>>>>>> ,
>>>>> on at least 5.1 (possibly 5.0.2 as well).  Any critical backwards
>>>>> compatibility problems if I do so?  Another alternative is to 
>>>>> close this
>>>>> issue as a "Won't Fix".  (As "referer" is an HTTP term:
>>>>> http://en.wikipedia.org/wiki/****HTTP_referer#Origin_of_the_****
>>>>> term_referer<http://en.wikipedia.org/wiki/**HTTP_referer#Origin_of_the_**term_referer> 
>>>>>
>>>>> <http://en.**wikipedia.org/wiki/HTTP_**referer#Origin_of_the_term_**
>>>>> referer<http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer> 
>>>>>
>>>>>> ,
>>>>> misspelled or not.)
>>>>>
>>>>> Thanks,
>>>>> Glen
>>>>>
>>>>>
>>>>>
>


Re: Rename RefererManager to ReferrerManager?

Posted by Anil Gangolli <an...@busybuddha.org>.
Part of the origin of the problem is that the HTTP 1.0 Header has the 
misspelling.  See
http://en.wikipedia.org/wiki/HTTP_referer for the history.  I think I 
made an effort long ago to correct it in our codebase where it was not a 
direct reference to the header name, but we may have regressed.

--a.

On 3/24/13 8:09 AM, Dave wrote:
> On Sun, Mar 24, 2013 at 9:51 AM, Glen Mazza <gl...@gmail.com> wrote:
>
>> I'll look at the source more thoroughly; we seem to be 50/50 between the
>> two spellings.  The *only* reason why I might want to apply it to 5.0.2 is
>> because this change affects several files and it makes it easier to
>> backport *other* patches and security fixes when the underlying files are
>> identical.
>>
> Very good point.
>
> - Dave
>
>
>
>> On 03/24/2013 09:22 AM, Dave wrote:
>>
>>> I could go either way on this one, so if you want to take action please
>>> decide and go ahead.
>>>
>>> However, I don't think we should address this in 5.0.x -- I think we
>>> should
>>> only address security issues and critical bugs there and a spelling error
>>> does not feel like a critical bug.
>>>
>>> Thanks,
>>> - Dave
>>>
>>>
>>>
>>> On Sun, Mar 24, 2013 at 7:25 AM, Glen Mazza <gl...@gmail.com> wrote:
>>>
>>>   Hi, I'd like to implement https://issues.apache.org/****
>>>> jira/browse/ROL-1229 <https://issues.apache.org/**jira/browse/ROL-1229><
>>>> https://**issues.apache.org/jira/browse/**ROL-1229<https://issues.apache.org/jira/browse/ROL-1229>
>>>>> ,
>>>> on at least 5.1 (possibly 5.0.2 as well).  Any critical backwards
>>>> compatibility problems if I do so?  Another alternative is to close this
>>>> issue as a "Won't Fix".  (As "referer" is an HTTP term:
>>>> http://en.wikipedia.org/wiki/****HTTP_referer#Origin_of_the_****
>>>> term_referer<http://en.wikipedia.org/wiki/**HTTP_referer#Origin_of_the_**term_referer>
>>>> <http://en.**wikipedia.org/wiki/HTTP_**referer#Origin_of_the_term_**
>>>> referer<http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer>
>>>>> ,
>>>> misspelled or not.)
>>>>
>>>> Thanks,
>>>> Glen
>>>>
>>>>
>>>>


Re: Rename RefererManager to ReferrerManager?

Posted by Dave <sn...@gmail.com>.
On Sun, Mar 24, 2013 at 9:51 AM, Glen Mazza <gl...@gmail.com> wrote:

> I'll look at the source more thoroughly; we seem to be 50/50 between the
> two spellings.  The *only* reason why I might want to apply it to 5.0.2 is
> because this change affects several files and it makes it easier to
> backport *other* patches and security fixes when the underlying files are
> identical.
>

Very good point.

- Dave



> On 03/24/2013 09:22 AM, Dave wrote:
>
>> I could go either way on this one, so if you want to take action please
>> decide and go ahead.
>>
>> However, I don't think we should address this in 5.0.x -- I think we
>> should
>> only address security issues and critical bugs there and a spelling error
>> does not feel like a critical bug.
>>
>> Thanks,
>> - Dave
>>
>>
>>
>> On Sun, Mar 24, 2013 at 7:25 AM, Glen Mazza <gl...@gmail.com> wrote:
>>
>>  Hi, I'd like to implement https://issues.apache.org/****
>>> jira/browse/ROL-1229 <https://issues.apache.org/**jira/browse/ROL-1229><
>>> https://**issues.apache.org/jira/browse/**ROL-1229<https://issues.apache.org/jira/browse/ROL-1229>
>>> >,
>>>
>>> on at least 5.1 (possibly 5.0.2 as well).  Any critical backwards
>>> compatibility problems if I do so?  Another alternative is to close this
>>> issue as a "Won't Fix".  (As "referer" is an HTTP term:
>>> http://en.wikipedia.org/wiki/****HTTP_referer#Origin_of_the_****
>>> term_referer<http://en.wikipedia.org/wiki/**HTTP_referer#Origin_of_the_**term_referer>
>>> <http://en.**wikipedia.org/wiki/HTTP_**referer#Origin_of_the_term_**
>>> referer<http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer>
>>> >,
>>>
>>> misspelled or not.)
>>>
>>> Thanks,
>>> Glen
>>>
>>>
>>>
>

Re: Rename RefererManager to ReferrerManager?

Posted by Glen Mazza <gl...@gmail.com>.
I'll look at the source more thoroughly; we seem to be 50/50 between the 
two spellings.  The *only* reason why I might want to apply it to 5.0.2 
is because this change affects several files and it makes it easier to 
backport *other* patches and security fixes when the underlying files 
are identical.

Glen

On 03/24/2013 09:22 AM, Dave wrote:
> I could go either way on this one, so if you want to take action please
> decide and go ahead.
>
> However, I don't think we should address this in 5.0.x -- I think we should
> only address security issues and critical bugs there and a spelling error
> does not feel like a critical bug.
>
> Thanks,
> - Dave
>
>
>
> On Sun, Mar 24, 2013 at 7:25 AM, Glen Mazza <gl...@gmail.com> wrote:
>
>> Hi, I'd like to implement https://issues.apache.org/**jira/browse/ROL-1229<https://issues.apache.org/jira/browse/ROL-1229>,
>> on at least 5.1 (possibly 5.0.2 as well).  Any critical backwards
>> compatibility problems if I do so?  Another alternative is to close this
>> issue as a "Won't Fix".  (As "referer" is an HTTP term:
>> http://en.wikipedia.org/wiki/**HTTP_referer#Origin_of_the_**term_referer<http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer>,
>> misspelled or not.)
>>
>> Thanks,
>> Glen
>>
>>


Re: Rename RefererManager to ReferrerManager?

Posted by Dave <sn...@gmail.com>.
I could go either way on this one, so if you want to take action please
decide and go ahead.

However, I don't think we should address this in 5.0.x -- I think we should
only address security issues and critical bugs there and a spelling error
does not feel like a critical bug.

Thanks,
- Dave



On Sun, Mar 24, 2013 at 7:25 AM, Glen Mazza <gl...@gmail.com> wrote:

> Hi, I'd like to implement https://issues.apache.org/**jira/browse/ROL-1229<https://issues.apache.org/jira/browse/ROL-1229>,
> on at least 5.1 (possibly 5.0.2 as well).  Any critical backwards
> compatibility problems if I do so?  Another alternative is to close this
> issue as a "Won't Fix".  (As "referer" is an HTTP term:
> http://en.wikipedia.org/wiki/**HTTP_referer#Origin_of_the_**term_referer<http://en.wikipedia.org/wiki/HTTP_referer#Origin_of_the_term_referer>,
> misspelled or not.)
>
> Thanks,
> Glen
>
>