You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Ramkumar Ramachandra <ar...@gmail.com> on 2010/08/06 15:30:10 UTC

Re: svn commit: r979282 - in /subversion/trunk/subversion/svnrdump: dump_editor.c dump_editor.h load_editor.c load_editor.h svnrdump.c

Hi Kamesh and Philip,

Philip Martin writes:
> Kamesh Jayachandran <ka...@collab.net> writes:
> 
> > On 07/26/2010 07:25 PM, artagnon@apache.org wrote:
> >> Author: artagnon
> >> Date: Mon Jul 26 13:55:25 2010
> >> New Revision: 979282
> >>
> >> URL: http://svn.apache.org/viewvc?rev=979282&view=rev
> >> Log:
> >> svnrdump: Add an a no-op load editor
> >>
> >> * subversion/svnrdump/svnrdump.c
> >>    (load_revisions): New function to fetch and drive the load
> >>    editor. Currently just fetches the load editor.
> >>    (load_cmd): Call load_revisions with the appropriate arguments.
> >>
> >> * subversion/svnrdump/load_editor.c
> >>    (get_load_editor): Add a no-op load editor.
> >>    
> >
> > Please name this function 'get_load_editor' as 'svnrdump__get_load_editor'.
> 
> You also need to #include load_editor.h in load_editor.c to make the
> prototype visible (possibly instead of dump_editor.h?)

Sorry about the late response- there was a huge amount of development
and API changes over the last week. I'm sure you'll agree that it's
quite unpleasant to type "svnrdump___get_load_editor" into gdb
everytime during development. Ofcourse, when everything starts working
and the API becomes more stable, I'll expose all re-usable
functionality. Thank you for understanding.

Also, please mark me on the TO or CC when specifically addressing my
commits- I have to handle massive volumes of email everyday, and I
sometimes miss email on which I'm not marked.

Thanks again.

-- Ram

Re: svn commit: r979282 - in /subversion/trunk/subversion/svnrdump: dump_editor.c dump_editor.h load_editor.c load_editor.h svnrdump.c

Posted by Daniel Shahaf <d....@daniel.shahaf.name>.
I don't see a reason not to adhere to the naming conventions from the start.

It's easier to write correct code once than to write buggy code and then
correct it...  (this theme is strong on my mind after reading through Bert's
commit diffs last night)

Ramkumar Ramachandra wrote on Fri, Aug 06, 2010 at 22:30:34 +0530:
> Hi Hyrum,
> 
> Hyrum K. Wright writes:
> > I don't think that "easy of typing into the debugger" should be a
> > primary qualification for API naming conventions...
> 
> Hehe, ofcourse. I just meant to say that I'll save the formal naming
> until I get past the point where the program can go a few seconds
> without segfaulting :)
> 
> -- Ram

Re: svn commit: r979282 - in /subversion/trunk/subversion/svnrdump: dump_editor.c dump_editor.h load_editor.c load_editor.h svnrdump.c

Posted by Ramkumar Ramachandra <ar...@gmail.com>.
Hi Hyrum,

Hyrum K. Wright writes:
> I don't think that "easy of typing into the debugger" should be a
> primary qualification for API naming conventions...

Hehe, ofcourse. I just meant to say that I'll save the formal naming
until I get past the point where the program can go a few seconds
without segfaulting :)

-- Ram

Re: svn commit: r979282 - in /subversion/trunk/subversion/svnrdump: dump_editor.c dump_editor.h load_editor.c load_editor.h svnrdump.c

Posted by "Hyrum K. Wright" <hy...@mail.utexas.edu>.
On Fri, Aug 6, 2010 at 10:30 AM, Ramkumar Ramachandra
<ar...@gmail.com> wrote:
> Hi Kamesh and Philip,
>
> Philip Martin writes:
>> Kamesh Jayachandran <ka...@collab.net> writes:
>>
>> > On 07/26/2010 07:25 PM, artagnon@apache.org wrote:
>> >> Author: artagnon
>> >> Date: Mon Jul 26 13:55:25 2010
>> >> New Revision: 979282
>> >>
>> >> URL: http://svn.apache.org/viewvc?rev=979282&view=rev
>> >> Log:
>> >> svnrdump: Add an a no-op load editor
>> >>
>> >> * subversion/svnrdump/svnrdump.c
>> >>    (load_revisions): New function to fetch and drive the load
>> >>    editor. Currently just fetches the load editor.
>> >>    (load_cmd): Call load_revisions with the appropriate arguments.
>> >>
>> >> * subversion/svnrdump/load_editor.c
>> >>    (get_load_editor): Add a no-op load editor.
>> >>
>> >
>> > Please name this function 'get_load_editor' as 'svnrdump__get_load_editor'.
>>
>> You also need to #include load_editor.h in load_editor.c to make the
>> prototype visible (possibly instead of dump_editor.h?)
>
> Sorry about the late response- there was a huge amount of development
> and API changes over the last week. I'm sure you'll agree that it's
> quite unpleasant to type "svnrdump___get_load_editor" into gdb
> everytime during development. Ofcourse, when everything starts working
> and the API becomes more stable, I'll expose all re-usable
> functionality. Thank you for understanding.

I don't think that "easy of typing into the debugger" should be a
primary qualification for API naming conventions...

-Hyrum