You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2023/12/26 09:49:46 UTC
(httpcomponents-client) branch master updated: Corrected release series in HttpClient 5.4-alpha1 release notes
This is an automated email from the ASF dual-hosted git repository.
olegk pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-client.git
The following commit(s) were added to refs/heads/master by this push:
new 7769a7edc Corrected release series in HttpClient 5.4-alpha1 release notes
7769a7edc is described below
commit 7769a7edc6a615a6e08a4d8664e30598cd0aabd6
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Tue Dec 26 10:49:34 2023 +0100
Corrected release series in HttpClient 5.4-alpha1 release notes
---
RELEASE_NOTES.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index 15a3d05c1..d9013c501 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -1,7 +1,7 @@
Release 5.4 ALPHA1
-------------------
-This is the first ALPHA release in the 5.3 release series that improves HTTP protocol support
+This is the first ALPHA release in the 5.4 release series that improves HTTP protocol support
by ensuring conformance to the latest HTTP specification (RFC 9110, RFC 9111, RFC 7616,
RFC 7617), ensures compatibility with Java Virtual Threads by replacing 'synchronized' keywords
in critical sections with Java lock primitives. The HTTP caching protocol layer has also been
@@ -13,7 +13,7 @@ with object serialization) created with any earlier version MUST be flushed and
or the cache backend MUST be configured to use the old deprecated cache entry serializer.
-Notable changes and features included in the 5.3 series:
+Notable changes and features included in the 5.4 series:
* Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).