You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Claus Ibsen (JIRA)" <ji...@apache.org> on 2013/05/26 14:35:20 UTC

[jira] [Updated] (CAMEL-6106) Make OnRedelivery available as a Pipeline as well as a Processor bean reference in OnException.

     [ https://issues.apache.org/jira/browse/CAMEL-6106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Claus Ibsen updated CAMEL-6106:
-------------------------------

    Fix Version/s: 3.0.0
    
> Make OnRedelivery available as a Pipeline as well as a Processor bean reference in OnException.
> -----------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-6106
>                 URL: https://issues.apache.org/jira/browse/CAMEL-6106
>             Project: Camel
>          Issue Type: New Feature
>          Components: camel-core
>    Affects Versions: 2.10.3
>            Reporter: Aaron Whiteside
>             Fix For: 3.0.0
>
>
> Make OnRedelivery available as a Pipeline as well as a Processor bean reference in OnException.
> Currently a Processor is supplied using a bean reference (in the Spring XML) like:
> {code}
> <onException onRedeliveryRef="myIORedeliverProcessor">
>     <exception>java.io.IOException</exception>
> </onException>
> {code}
> It would be much nicer to be able to supply it like:
> {code}
> <onException>
>     <exception>java.io.IOException</exception>
>     <onRedelivery>
>         <log message="Msg is about to be retried"/>
>         <transform><constant>hello world</constant></transform>
>     </onRedelivery>
> </onException>
> {code}
> The onRedelivery element would just be a PipelineProcessor underneath called in the same situation as the onRedeliveryRef Processor bean.
> Also perhaps <beforeRedelivery> might be a better name? Either way being able to supply routing constructs in XML would be much nicer and easier to use than supplying a reference.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira