You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Flink Jira Bot (Jira)" <ji...@apache.org> on 2021/06/08 10:46:02 UTC

[jira] [Updated] (FLINK-12003) Revert the config option about mapreduce.output.basename in HadoopOutputFormatBase

     [ https://issues.apache.org/jira/browse/FLINK-12003?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Flink Jira Bot updated FLINK-12003:
-----------------------------------
    Labels: auto-unassigned stale-major  (was: auto-unassigned)

I am the [Flink Jira Bot|https://github.com/apache/flink-jira-bot/] and I help the community manage its development. I see this issues has been marked as Major but is unassigned and neither itself nor its Sub-Tasks have been updated for 30 days. I have gone ahead and added a "stale-major" to the issue". If this ticket is a Major, please either assign yourself or give an update. Afterwards, please remove the label or in 7 days the issue will be deprioritized.


> Revert the config option about mapreduce.output.basename in HadoopOutputFormatBase
> ----------------------------------------------------------------------------------
>
>                 Key: FLINK-12003
>                 URL: https://issues.apache.org/jira/browse/FLINK-12003
>             Project: Flink
>          Issue Type: Improvement
>          Components: Connectors / Hadoop Compatibility
>            Reporter: vinoyang
>            Priority: Major
>              Labels: auto-unassigned, stale-major
>
> In {{HadoopOutputFormatBase}} open method, the config option {{mapreduce.output.basename}} was changed to "tmp" and there is not any documentation state this change.
> By default, HDFS will use this format "part-x-yyyyy" to name its file, the x and y means : 
>  * {{x}} is either 'm' or 'r', depending on whether the job was a map only job, or reduce
>  * {{yyyyy}} is the mapper or reducer task number (zero based)
>  
> The keyword "part" has used in many place in user's business logic to match the hdfs's file name. So I suggest to revert this config option or document it.
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)