You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@couchdb.apache.org by "Paul Joseph Davis (JIRA)" <ji...@apache.org> on 2017/02/24 19:34:44 UTC

[jira] [Created] (COUCHDB-3309) Remove disk_size, data_size and other.data_size attribute from db info blobs

Paul Joseph Davis created COUCHDB-3309:
------------------------------------------

             Summary: Remove disk_size, data_size and other.data_size attribute from db info blobs
                 Key: COUCHDB-3309
                 URL: https://issues.apache.org/jira/browse/COUCHDB-3309
             Project: CouchDB
          Issue Type: Bug
          Components: HTTP Interface
            Reporter: Paul Joseph Davis


Since 2.0 we've had duplicate keys in our database info blobs for size fields. I was going to remove these as part of the storage engine work but that'd be backwards incompatible. I'm opening this ticket and setting it as blocking for 3.0 so that we remember to remove them when we can make backward incompatible changes.

Also, to be clear, these are duplicates. The same data is available under the sizes key with extremely less ambiguous naming (and will be configurable for storage engines to return whatever they want there).

{code}
{
    "compact_running": false,
    "data_size": 23403,
    "db_name": "test-db",
    "disk_format_version": 6,
    "disk_size": 513032,
    "doc_count": 10,
    "doc_del_count": 2,
    "instance_start_time": "0",
    "other": {
        "data_size": 6020
    },
    "purge_seq": 0,
    "sizes": {
        "active": 23403,
        "external": 6020,
        "file": 513032
    },
    "update_seq": "82-g1AAAADveJzLYWBgYMlgTmFQSklKzi9KdUhJMjLWy83PzyvOyMxL1UvOyS9NScwr0ctLLckBqmVKZEiy____f1YiH5ouU3y6khyAZFI9No2GeDXmsQBJhgYgBdS7PytRAs1WQ8KaD0A0A22WywIAA-tQaQ"
}
{code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)