You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by "Abdullah Shaikh (JIRA)" <ji...@apache.org> on 2009/09/30 08:30:32 UTC

[jira] Created: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
-------------------------------------------------------------------------------------------

                 Key: OFBIZ-2978
                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
             Project: OFBiz
          Issue Type: Bug
          Components: accounting
            Reporter: Abdullah Shaikh


In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".

I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Reopened: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Abdullah Shaikh (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Abdullah Shaikh reopened OFBIZ-2978:
------------------------------------


The code calling the service savePaymentGatewayResponse is attempting to use it for saving both PaymentGatewayResponse and PaymentGatewayRespMsg, but it is only capable of handling the former.

The savePgr method, calls savePaymentGatewayResponse service, and is called from multiple places, this method expects 2 parameters, DispatchContext & GenericValue, but the issue is the calling code which calls savePgr method passes PaymentGatewayResponse in some places and PaymentGatewayRespMsg in some places.

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Scott Gray
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Scott Gray (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Gray closed OFBIZ-2978.
-----------------------------

       Resolution: Fixed
    Fix Version/s: SVN trunk

Thanks Abdullah, this is fixed in r821705

After looking at the revision history for the methods I decided that the original intention was to support both types of values but at some point someone committed an accidental 'fix' which reduced the support down to PaymentGatewayResponse values only.
So I decided in the end that the best way to fix this was to restore the original intention and simply improve the fix which broke that functionality.

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Scott Gray
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch, OFBIZ-2978_gatewayMessage should be pgrMessage.patch, OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Abdullah Shaikh (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Abdullah Shaikh updated OFBIZ-2978:
-----------------------------------

    Attachment: OFBIZ-2978_gatewayMessage should be pgrMessage.patch

I have changed the service definition to include paymentGatewayRespMsg as parameter and made both the parameters, paymentGatewayResponse & paymentGatewayRespMsg optional, and checked which parameter has been passed.

I have created savePgrMessage method, and changed the calling code where paymentGatewayRespMsg is being passed, now instead of savePgr it will call savePgrMessage, as we could not decided which parameter is passed in savePgr.

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Scott Gray
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch, OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Abdullah Shaikh (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Abdullah Shaikh updated OFBIZ-2978:
-----------------------------------

    Attachment: OFBIZ-2978_gatewayMessage should be pgrMessage.patch

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Scott Gray (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Scott Gray closed OFBIZ-2978.
-----------------------------

    Resolution: Invalid
      Assignee: Scott Gray

I'm sorry Abdullah, I didn't look into the details when I responded to your email, I just responded based on the information you provided.

PaymentGatewayResponse does have a field called gatewayMessage and the purpose of the service is to save a PaymentGatewayResponse not a PaymentGatewayResponseMsg.

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Scott Gray
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (OFBIZ-2978) gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices

Posted by "Abdullah Shaikh (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-2978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Abdullah Shaikh updated OFBIZ-2978:
-----------------------------------

    Attachment: OFBIZ-2978_gatewayMessage should be pgrMessage.patch

Changed GenericDelegator delegator = dctx.getDelegator(); to Delegator delegator = dctx.getDelegator(); in savePaymentGatewayResponse, as all the GenericDelegator class reference are converted to Delegator interface references after this patch was submitted, so updated the patch to reflect those changes.

> gatewayMessage should be pgrMessage in savePaymentGatewayResponse of PaymentGatewayServices
> -------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-2978
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-2978
>             Project: OFBiz
>          Issue Type: Bug
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Scott Gray
>         Attachments: OFBIZ-2978_gatewayMessage should be pgrMessage.patch, OFBIZ-2978_gatewayMessage should be pgrMessage.patch, OFBIZ-2978_gatewayMessage should be pgrMessage.patch
>
>
> In savePaymentGatewayResponse method of PaymentGatewayServices class, we are setting the "gatewayMessage" field on the GenericValue of PaymentGatewayRespMsg, but there is no field named "gatewayMessage" in entity PaymentGatewayRespMsg but instead we need to use "pgrMessage" in place of "gatewayMessage".
> I guess we mistakely assumed the GenericValue which we get from the context, context.get("paymentGatewayResponse");, to be of PaymentGatewayResponse, but its the GenericValue of PaymentGatewayRespMsg but while putting it on the context we named it as "paymentGatewayResponse".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.