You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@deltaspike.apache.org by "Gerhard Petracek (Created) (JIRA)" <ji...@apache.org> on 2011/12/21 12:27:30 UTC

[jira] [Created] (DELTASPIKE-20) move util methods to CdiUtils

move util methods to CdiUtils
-----------------------------

                 Key: DELTASPIKE-20
                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
             Project: DeltaSpike
          Issue Type: Sub-task
            Reporter: Gerhard Petracek
            Assignee: Gerhard Petracek




--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Closed] (DELTASPIKE-20) move util methods to BeanProvider

Posted by "Gerhard Petracek (Closed) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek closed DELTASPIKE-20.
--------------------------------------

    
> move util methods to BeanProvider
> ---------------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>             Fix For: 0.1-incubating
>
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Jason Porter (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175249#comment-13175249 ] 

Jason Porter commented on DELTASPIKE-20:
----------------------------------------

What's the optionalBeanAllowed param drive?
                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Assigned] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Gerhard Petracek (Assigned) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek reassigned DELTASPIKE-20:
------------------------------------------

    Assignee: Mark Struberg  (was: Gerhard Petracek)
    
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Gerhard Petracek (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek resolved DELTASPIKE-20.
----------------------------------------

    Resolution: Fixed
    
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>             Fix For: 0.1-SNAPSHOT
>
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Jason Porter (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175352#comment-13175352 ] 

Jason Porter commented on DELTASPIKE-20:
----------------------------------------

Okay, got it, thanks.
                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Gerhard Petracek (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek updated DELTASPIKE-20:
---------------------------------------

    Description: 
public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)

public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
    
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Gerhard Petracek
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Mark Struberg (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mark Struberg resolved DELTASPIKE-20.
-------------------------------------

       Resolution: Fixed
    Fix Version/s: 0.1-SNAPSHOT

resolved as part of the work for DELTASPIKE-17
                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>             Fix For: 0.1-SNAPSHOT
>
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Gerhard Petracek (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175348#comment-13175348 ] 

Gerhard Petracek commented on DELTASPIKE-20:
--------------------------------------------

if you provide a name, type,... and there is no cdi bean for it the behaviour is different.
optionalBeanAllowed == false && cdiBeanFound == false -> throw an exception
optionalBeanAllowed == true && cdiBeanFound == false -> return null

the alternative would be to return null and every caller has to do the exception part (if a cdi bean isn't optional) -> we will see different exceptions for the same reason.

                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Reopened] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Gerhard Petracek (Reopened) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek reopened DELTASPIKE-20:
----------------------------------------


#getContextualReferences is missing
                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>             Fix For: 0.1-SNAPSHOT
>
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (DELTASPIKE-20) move util methods to BeanProvider

Posted by "Gerhard Petracek (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gerhard Petracek updated DELTASPIKE-20:
---------------------------------------

    Description: 
public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)

public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

  was:
public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)

public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

        Summary: move util methods to BeanProvider  (was: move util methods to CdiUtils)
    
> move util methods to BeanProvider
> ---------------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>             Fix For: 0.1-SNAPSHOT
>
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (DELTASPIKE-20) move util methods to CdiUtils

Posted by "Mark Struberg (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/DELTASPIKE-20?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13176549#comment-13176549 ] 

Mark Struberg commented on DELTASPIKE-20:
-----------------------------------------

CdiUtils sounds a bit too loose. I'd rather name it ContextualInstanceProvider and let it resolve the BeanManager internally.
                
> move util methods to CdiUtils
> -----------------------------
>
>                 Key: DELTASPIKE-20
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-20
>             Project: DeltaSpike
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Gerhard Petracek
>            Assignee: Mark Struberg
>
> public <T> T getContextualReference(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)
> public <T> T getContextualReference(String name, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> T getContextualReference(Bean<T> bean, boolean optionalBeanAllowed, Class<T> targetType)
> public <T> List<T> getContextualReferences(Class<T> type, boolean optionalBeanAllowed, Annotation... qualifiers)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira