You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pirk.apache.org by Tim Ellison <t....@gmail.com> on 2016/08/10 15:51:14 UTC

Re: QueryInfo.queryNum

On 10/08/16 15:34, Ellison Anne Williams wrote:
> First, there are some wacko comments that I made in that pull request that
> I tried to delete but don't appear to have quite cleared (in my haste, I
> started making comments before going through all of the changes - turns out
> I was looking at the changes in the wrong way and then tried to delete...
> and failed.. and then let confusion ensue... won't do that again...)

:-)

> The queryID (originally the queryName in the code) is the user-assigned ID
> of the query. Currently, the user can embed whatever info they would like
> in the ID -- Pirk doesn't 'do' anything to it other than maintain it. Thus,
> I think that changing it to a UUID object makes sense. In that case, we
> will be using the toString and fromString methods of the UUID class to
> write/parse the ID.

There is currently a queryNum (double) and a queryName (String) that
both seem to be simply used to identify the query for the benefit of the
end user.  How about I combine them into a single UUID identifier?

Regards,
Tim

Re: QueryInfo.queryNum

Posted by Walter Ray-Dulany <ra...@gmail.com>.
+1 sounds good

On Aug 10, 2016 12:25, "Ellison Anne Williams" <ea...@gmail.com>
wrote:

> +1 Combining sounds good to me
>
> On Wed, Aug 10, 2016 at 11:58 AM, Suneel Marthi <su...@gmail.com>
> wrote:
>
> > On Wed, Aug 10, 2016 at 11:51 AM, Tim Ellison <t....@gmail.com>
> > wrote:
> >
> > > On 10/08/16 15:34, Ellison Anne Williams wrote:
> > > > First, there are some wacko comments that I made in that pull request
> > > that
> > > > I tried to delete but don't appear to have quite cleared (in my
> haste,
> > I
> > > > started making comments before going through all of the changes -
> turns
> > > out
> > > > I was looking at the changes in the wrong way and then tried to
> > delete...
> > > > and failed.. and then let confusion ensue... won't do that again...)
> > >
> > > :-)
> > >
> > > > The queryID (originally the queryName in the code) is the
> user-assigned
> > > ID
> > > > of the query. Currently, the user can embed whatever info they would
> > like
> > > > in the ID -- Pirk doesn't 'do' anything to it other than maintain it.
> > > Thus,
> > > > I think that changing it to a UUID object makes sense. In that case,
> we
> > > > will be using the toString and fromString methods of the UUID class
> to
> > > > write/parse the ID.
> > >
> > > There is currently a queryNum (double) and a queryName (String) that
> > > both seem to be simply used to identify the query for the benefit of
> the
> > > end user.  How about I combine them into a single UUID identifier?
> > >
> > > +1
> >
> >
> > > Regards,
> > > Tim
> > >
> >
>

Re: QueryInfo.queryNum

Posted by Ellison Anne Williams <ea...@gmail.com>.
+1 Combining sounds good to me

On Wed, Aug 10, 2016 at 11:58 AM, Suneel Marthi <su...@gmail.com>
wrote:

> On Wed, Aug 10, 2016 at 11:51 AM, Tim Ellison <t....@gmail.com>
> wrote:
>
> > On 10/08/16 15:34, Ellison Anne Williams wrote:
> > > First, there are some wacko comments that I made in that pull request
> > that
> > > I tried to delete but don't appear to have quite cleared (in my haste,
> I
> > > started making comments before going through all of the changes - turns
> > out
> > > I was looking at the changes in the wrong way and then tried to
> delete...
> > > and failed.. and then let confusion ensue... won't do that again...)
> >
> > :-)
> >
> > > The queryID (originally the queryName in the code) is the user-assigned
> > ID
> > > of the query. Currently, the user can embed whatever info they would
> like
> > > in the ID -- Pirk doesn't 'do' anything to it other than maintain it.
> > Thus,
> > > I think that changing it to a UUID object makes sense. In that case, we
> > > will be using the toString and fromString methods of the UUID class to
> > > write/parse the ID.
> >
> > There is currently a queryNum (double) and a queryName (String) that
> > both seem to be simply used to identify the query for the benefit of the
> > end user.  How about I combine them into a single UUID identifier?
> >
> > +1
>
>
> > Regards,
> > Tim
> >
>

Re: QueryInfo.queryNum

Posted by Suneel Marthi <su...@gmail.com>.
On Wed, Aug 10, 2016 at 11:51 AM, Tim Ellison <t....@gmail.com> wrote:

> On 10/08/16 15:34, Ellison Anne Williams wrote:
> > First, there are some wacko comments that I made in that pull request
> that
> > I tried to delete but don't appear to have quite cleared (in my haste, I
> > started making comments before going through all of the changes - turns
> out
> > I was looking at the changes in the wrong way and then tried to delete...
> > and failed.. and then let confusion ensue... won't do that again...)
>
> :-)
>
> > The queryID (originally the queryName in the code) is the user-assigned
> ID
> > of the query. Currently, the user can embed whatever info they would like
> > in the ID -- Pirk doesn't 'do' anything to it other than maintain it.
> Thus,
> > I think that changing it to a UUID object makes sense. In that case, we
> > will be using the toString and fromString methods of the UUID class to
> > write/parse the ID.
>
> There is currently a queryNum (double) and a queryName (String) that
> both seem to be simply used to identify the query for the benefit of the
> end user.  How about I combine them into a single UUID identifier?
>
> +1


> Regards,
> Tim
>