You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@tika.apache.org by ma...@apache.org on 2016/01/24 19:02:10 UTC

[1/2] tika git commit: The testGetJSON() method had a strange cast to (Object) that I removed to improve readability and maintainability. This was identified by findbugs rule BC_IMPOSSIBLE_CAST.

Repository: tika
Updated Branches:
  refs/heads/master fe841bc87 -> efb645ef4


The testGetJSON() method had a strange cast to (Object) that I removed to improve readability and maintainability. This was identified by findbugs rule BC_IMPOSSIBLE_CAST.


Project: http://git-wip-us.apache.org/repos/asf/tika/repo
Commit: http://git-wip-us.apache.org/repos/asf/tika/commit/c42b5ad8
Tree: http://git-wip-us.apache.org/repos/asf/tika/tree/c42b5ad8
Diff: http://git-wip-us.apache.org/repos/asf/tika/diff/c42b5ad8

Branch: refs/heads/master
Commit: c42b5ad80e73c93bf3f4be1a7f428db45ebc2683
Parents: fe841bc
Author: Marc Breslow <ma...@devfactory.com>
Authored: Sat Jan 23 12:36:30 2016 -0500
Committer: Marc Breslow <ma...@devfactory.com>
Committed: Sat Jan 23 12:36:30 2016 -0500

----------------------------------------------------------------------
 .../src/test/java/org/apache/tika/server/TikaDetectorsTest.java  | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/tika/blob/c42b5ad8/tika-server/src/test/java/org/apache/tika/server/TikaDetectorsTest.java
----------------------------------------------------------------------
diff --git a/tika-server/src/test/java/org/apache/tika/server/TikaDetectorsTest.java b/tika-server/src/test/java/org/apache/tika/server/TikaDetectorsTest.java
index 21bece3..6bbfbf2 100644
--- a/tika-server/src/test/java/org/apache/tika/server/TikaDetectorsTest.java
+++ b/tika-server/src/test/java/org/apache/tika/server/TikaDetectorsTest.java
@@ -100,7 +100,7 @@ public class TikaDetectorsTest extends CXFTestBase {
                 .get();
 
         String jsonStr = getStringFromInputStream((InputStream) response.getEntity());
-        Map<String, Map<String, Object>> json = (Map<String, Map<String, Object>>) JSON.parse(jsonStr);
+        Map<String, Object> json = (Map<String, Object>) JSON.parse(jsonStr);
 
         // Should have a nested structure
         assertTrue(json.containsKey("name"));
@@ -110,7 +110,7 @@ public class TikaDetectorsTest extends CXFTestBase {
         assertEquals(Boolean.TRUE, json.get("composite"));
 
         // At least 4 child detectors, none of them composite
-        Object[] children = (Object[]) (Object) json.get("children");
+        Object[] children = (Object[]) json.get("children");
         assertTrue(children.length >= 4);
         boolean hasOgg = false, hasPOIFS = false, hasZIP = false, hasMime = false;
         for (Object o : children) {


[2/2] tika git commit: Update to record change for GH #73 contributed by Marc Breslow this closes #73.

Posted by ma...@apache.org.
Update to record change for GH #73 contributed by Marc Breslow <ma...@devfactory.com> this closes #73.


Project: http://git-wip-us.apache.org/repos/asf/tika/repo
Commit: http://git-wip-us.apache.org/repos/asf/tika/commit/efb645ef
Tree: http://git-wip-us.apache.org/repos/asf/tika/tree/efb645ef
Diff: http://git-wip-us.apache.org/repos/asf/tika/diff/efb645ef

Branch: refs/heads/master
Commit: efb645ef4ba159652a4e4de0079ef08b9855ed03
Parents: c42b5ad
Author: Chris Mattmann <ma...@apache.org>
Authored: Sun Jan 24 10:01:54 2016 -0800
Committer: Chris Mattmann <ma...@apache.org>
Committed: Sun Jan 24 10:01:54 2016 -0800

----------------------------------------------------------------------
 CHANGES.txt | 3 +++
 1 file changed, 3 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/tika/blob/efb645ef/CHANGES.txt
----------------------------------------------------------------------
diff --git a/CHANGES.txt b/CHANGES.txt
index ad05659..d00ceca 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,5 +1,8 @@
 Release 1.12 - Current Development
 
+  * JSON tests in Tika server were updated to remove impossible casts
+    (Github-73).
+
   * Fix bug in GeoTopicParser where NER is reused instead of instantiated
     with each request (TIKA-1834).