You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Stefan Sperling <st...@elego.de> on 2008/06/01 09:18:40 UTC

Re: svn commit: r31550 - trunk/subversion/libsvn_ra_serf

On Sun, Jun 01, 2008 at 02:04:45AM -0700, lgo@tigris.org wrote:
> Author: lgo
> Date: Sun Jun  1 02:04:44 2008
> New Revision: 31550
> 
> Log:
> ra_serf: When querying the base properties from the repository, read and cache
> the uuid in the session.
 

> -  if (!*uuid)
> +  if (!session->uuid)

Interesting. Just yesterday I was pointing out that in a patch
submitted to the list, there were no spaces after the ! operator,
like this:

  if (! session->uuid)

Turns out I cannot find anything on this in neither HACKING nor
the GNU coding standards. Well, some example code in HACKING puts
a space after !, but that's hardly a guideline.

Is there a convention about this? Not that I think we really need
one. I just assumed there was one because most (all?) of Subversion's
code I've seen so far does put a space there...

Stefan

Re: svn commit: r31550 - trunk/subversion/libsvn_ra_serf

Posted by Lieven Govaerts <sv...@mobsol.be>.
Stefan Sperling wrote:
> On Sun, Jun 01, 2008 at 02:04:45AM -0700, lgo@tigris.org wrote:
>> Author: lgo
>> Date: Sun Jun  1 02:04:44 2008
>> New Revision: 31550
>>
>> Log:
>> ra_serf: When querying the base properties from the repository, read and cache
>> the uuid in the session.
>  
> 
>> -  if (!*uuid)
>> +  if (!session->uuid)
> 
> Interesting. Just yesterday I was pointing out that in a patch
> submitted to the list, there were no spaces after the ! operator,
> like this:
> 
>   if (! session->uuid)
> 
> Turns out I cannot find anything on this in neither HACKING nor
> the GNU coding standards. Well, some example code in HACKING puts
> a space after !, but that's hardly a guideline.
> 
> Is there a convention about this? Not that I think we really need
> one. I just assumed there was one because most (all?) of Subversion's
> code I've seen so far does put a space there...

You can find examples of both in the code, but in ra_serf the 
without-space variant is used consistently. The few exceptions are where 
multiple brackets are used, as in:
     if (! ((dir->added && !dir->copy_path) ||

Here the space between (! and (( helps readability, where as for me it's 
not needed in '!dir->copy_path'.

Lieven

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org