You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Arpit Agarwal (JIRA)" <ji...@apache.org> on 2015/06/23 19:55:02 UTC
[jira] [Comment Edited] (HDFS-7390) Provide JMX metrics per storage
type
[ https://issues.apache.org/jira/browse/HDFS-7390?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14598051#comment-14598051 ]
Arpit Agarwal edited comment on HDFS-7390 at 6/23/15 5:54 PM:
--------------------------------------------------------------
Hi [~benoyantony],
# We should replace _TieredStorage_ with _ByStorageType_ or similar everywhere. HDFS knows nothing about the hierarchy of storage types.
# It looks like {{StorageTypeStats#add}} will add each node multiple times i.e. once per storage. I understand why you added {{nodesInService}} count in {{StorageTypeStats}}. We can have separate routines - addNode and addUsageStats or similar.
# Missing audience and stability annotations on public class {{StorageTypeStats}}.
# Nitpick. Couple of Coding style issues: Need spaces around operators e.g. in {{storageInfo:node}}.
The patch looks good otherwise.
was (Author: arpitagarwal):
Hi [~benoyantony],
# We should rename _TieredStorage_ with _ByStorageType_ or similar everywhere? HDFS knows nothing about the hierarchy of storage types.
# It looks like {{StorageTypeStats#add}} will add each node multiple times i.e. once per storage. I understand why you added {{nodesInService}} count in {{StorageTypeStats}}. We can have separate routines - addNode and addUsageStats or similar.
# Missing audience and stability annotations on public class {{StorageTypeStats}}.
# Nitpick. Couple of Coding style issues: Need spaces around operators e.g. in {{storageInfo:node}}.
The patch looks good otherwise.
> Provide JMX metrics per storage type
> ------------------------------------
>
> Key: HDFS-7390
> URL: https://issues.apache.org/jira/browse/HDFS-7390
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Affects Versions: 2.5.2
> Reporter: Benoy Antony
> Assignee: Benoy Antony
> Labels: BB2015-05-TBR
> Attachments: HDFS-7390-003.patch, HDFS-7390-004.patch, HDFS-7390-005.patch, HDFS-7390.patch, HDFS-7390.patch
>
>
> HDFS-2832 added heterogeneous support. In a cluster with different storage types, it is useful to have metrics per storage type.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)