You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mahout.apache.org by "Jeff Eastman (JIRA)" <ji...@apache.org> on 2008/04/14 20:39:05 UTC

[jira] Commented: (MAHOUT-39) Vector improvments

    [ https://issues.apache.org/jira/browse/MAHOUT-39?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12588694#action_12588694 ] 

Jeff Eastman commented on MAHOUT-39:
------------------------------------

-1

Vector#assign already implements fill(double) functionality. I don't know exactly what you have in mind for the fill(double, int, int) operator, but make sure you've looked at all the assign variants before pursuing this. Finally, copy and like do return the same underlying types as the receiver.

> Vector improvments
> ------------------
>
>                 Key: MAHOUT-39
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-39
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Karl Wettin
>            Assignee: Karl Wettin
>         Attachments: MAHOUT-39.txt
>
>
>  * Vector#fill(double)
>  * Vector#fill(double, int, in)
>  * implementations of copy() and like() don't return typed subclasses

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Re: [jira] Commented: (MAHOUT-39) Vector improvments

Posted by Jeff Eastman <je...@windwardsolutions.com>.
Ted Dunning wrote:
> Or provide sample code as documentation for common idioms (faq.java, as it
> were)?
>
>
> On 4/14/08 2:32 PM, "Jeff Eastman" <je...@windwardsolutions.com> wrote:
>
>   
>> I agree that the assign semantics might not be apparent to somebody
>> wanting to fill a vector or matrix. Perhaps we could rename the method
>> rather than introducing something redundant?
>>     
>
>
>   
Sure, I really think the assign() name is fine and all of its forms are 
pretty useful. Some documentation of common idioms would be an 
improvement over name changes, IMHO.

Jeff

Re: [jira] Commented: (MAHOUT-39) Vector improvments

Posted by Ted Dunning <td...@veoh.com>.
Or provide sample code as documentation for common idioms (faq.java, as it
were)?


On 4/14/08 2:32 PM, "Jeff Eastman" <je...@windwardsolutions.com> wrote:

> I agree that the assign semantics might not be apparent to somebody
> wanting to fill a vector or matrix. Perhaps we could rename the method
> rather than introducing something redundant?


Re: [jira] Commented: (MAHOUT-39) Vector improvments

Posted by Jeff Eastman <je...@windwardsolutions.com>.
Ted Dunning wrote:
> IF Karl missed the assign operations, then others will too.  Having his
> implementations might help others realize what assign can do.
>
>
> On 4/14/08 11:39 AM, "Jeff Eastman (JIRA)" <ji...@apache.org> wrote:
>
>   
>>     [ 
>> https://issues.apache.org/jira/browse/MAHOUT-39?page=com.atlassian.jira.plugin
>> .system.issuetabpanels:comment-tabpanel&focusedCommentId=12588694#action_12588
>> 694 ] 
>>
>> Jeff Eastman commented on MAHOUT-39:
>> ------------------------------------
>>
>> -1
>>
>> Vector#assign already implements fill(double) functionality. I don't know
>> exactly what you have in mind for the fill(double, int, int) operator, but
>> make sure you've looked at all the assign variants before pursuing this.
>> Finally, copy and like do return the same underlying types as the receiver.
>>
>>     
>>> Vector improvments
>>> ------------------
>>>
>>>                 Key: MAHOUT-39
>>>                 URL: https://issues.apache.org/jira/browse/MAHOUT-39
>>>             Project: Mahout
>>>          Issue Type: Improvement
>>>            Reporter: Karl Wettin
>>>            Assignee: Karl Wettin
>>>         Attachments: MAHOUT-39.txt
>>>
>>>
>>>  * Vector#fill(double)
>>>  * Vector#fill(double, int, in)
>>>  * implementations of copy() and like() don't return typed subclasses
>>>       
>
>
>   
I agree that the assign semantics might not be apparent to somebody 
wanting to fill a vector or matrix. Perhaps we could rename the method 
rather than introducing something redundant?

Jeff

Re: [jira] Commented: (MAHOUT-39) Vector improvments

Posted by Ted Dunning <td...@veoh.com>.

IF Karl missed the assign operations, then others will too.  Having his
implementations might help others realize what assign can do.


On 4/14/08 11:39 AM, "Jeff Eastman (JIRA)" <ji...@apache.org> wrote:

> 
>     [ 
> https://issues.apache.org/jira/browse/MAHOUT-39?page=com.atlassian.jira.plugin
> .system.issuetabpanels:comment-tabpanel&focusedCommentId=12588694#action_12588
> 694 ] 
> 
> Jeff Eastman commented on MAHOUT-39:
> ------------------------------------
> 
> -1
> 
> Vector#assign already implements fill(double) functionality. I don't know
> exactly what you have in mind for the fill(double, int, int) operator, but
> make sure you've looked at all the assign variants before pursuing this.
> Finally, copy and like do return the same underlying types as the receiver.
> 
>> Vector improvments
>> ------------------
>> 
>>                 Key: MAHOUT-39
>>                 URL: https://issues.apache.org/jira/browse/MAHOUT-39
>>             Project: Mahout
>>          Issue Type: Improvement
>>            Reporter: Karl Wettin
>>            Assignee: Karl Wettin
>>         Attachments: MAHOUT-39.txt
>> 
>> 
>>  * Vector#fill(double)
>>  * Vector#fill(double, int, in)
>>  * implementations of copy() and like() don't return typed subclasses