You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@crunch.apache.org by "Gabriel Reid (JIRA)" <ji...@apache.org> on 2013/05/26 08:08:21 UTC
[jira] [Commented] (CRUNCH-210) Update cogroup functions to use
mapValues functions
[ https://issues.apache.org/jira/browse/CRUNCH-210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13667213#comment-13667213 ]
Gabriel Reid commented on CRUNCH-210:
-------------------------------------
Looks good to me, other than one nitpick: I like the addition of a parameter to specify the number of reducers, but I don't think that it should be called parallelism -- I would prefer either numReducers or numPartitions.
The only other place that the name "parallelism" is used is in Cartesian, and it has a totally different meaning there, so I think using the same name here is confusing (it threw me off when I first saw it in the patch).
> Update cogroup functions to use mapValues functions
> ---------------------------------------------------
>
> Key: CRUNCH-210
> URL: https://issues.apache.org/jira/browse/CRUNCH-210
> Project: Crunch
> Issue Type: Bug
> Reporter: Josh Wills
> Attachments: CRUNCH-210.patch
>
>
> Removing some deprecated MapValuesFn references in the CoGroup library and adding support for users to specify an arbitrary level of parallelism on their CoGroup jobs.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira