You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@activemq.apache.org by "Lionel Cons (JIRA)" <ji...@apache.org> on 2016/05/20 12:02:12 UTC

[jira] [Created] (ARTEMIS-528) The "lock" directory should be configurable

Lionel Cons created ARTEMIS-528:
-----------------------------------

             Summary: The "lock" directory should be configurable
                 Key: ARTEMIS-528
                 URL: https://issues.apache.org/jira/browse/ARTEMIS-528
             Project: ActiveMQ Artemis
          Issue Type: Improvement
            Reporter: Lionel Cons


Artemis allows the broker owner to change most of the paths used, see for instance the "*-directory" elements like "paging-directory". There is one major exception though.

The directory holding the {{cli.lock}} file is currently hard-coded in {{artemis-cli/src/main/java/org/apache/activemq/artemis/cli/commands/Configurable.java}} (sic):

{code}
   protected File getLockPlace() throws Exception {
      String brokerInstance = getBrokerInstance();
      if (brokerInstance != null) {
         return new File(new File(brokerInstance),"lock");
      }
      else {
         return null;
      }
   }
{code}

Could you please allow changing the name of this directory?

Ideally, it could appear like the other "*-directory" elements in {{broker.xml}}. If this is too late, it could come from a Java property such as {{artemis.lockdir}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)