You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Jonathan Hsieh (JIRA)" <ji...@apache.org> on 2013/09/10 02:06:52 UTC
[jira] [Comment Edited] (HBASE-9477) Add deprecation compat shim
for Result#raw and Result#list for 0.96
[ https://issues.apache.org/jira/browse/HBASE-9477?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13762496#comment-13762496 ]
Jonathan Hsieh edited comment on HBASE-9477 at 9/10/13 12:05 AM:
-----------------------------------------------------------------
The deprecated methods would only be applied to 0.96 (not 0.98)
was (Author: jmhsieh):
This would only be applied to 0.96 (not 0.98)
> Add deprecation compat shim for Result#raw and Result#list for 0.96
> -------------------------------------------------------------------
>
> Key: HBASE-9477
> URL: https://issues.apache.org/jira/browse/HBASE-9477
> Project: HBase
> Issue Type: Sub-task
> Affects Versions: 0.95.2
> Reporter: Jonathan Hsieh
> Assignee: Jonathan Hsieh
> Priority: Blocker
> Fix For: 0.96.0
>
> Attachments: hbase-9477.patch
>
>
> Discussion in HBASE-9359 brought up that applications commonly use the Keyvalue[] Result#raw (and similarly Result#list). Let's rename the 0.96 version to something like #listCells and #rawCells and revert #raw and #list to their old signature to easy upgrade deprecation issues.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira