You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Roger Whitcomb (JIRA)" <ji...@apache.org> on 2019/08/12 22:11:00 UTC

[jira] [Commented] (PIVOT-1045) Refactor read-only classes to use a common abstract class to reduce code

    [ https://issues.apache.org/jira/browse/PIVOT-1045?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16905627#comment-16905627 ] 

Roger Whitcomb commented on PIVOT-1045:
---------------------------------------

First iteration:

Sending core\src\org\apache\pivot\collections\ArrayAdapter.java
Sending core\src\org\apache\pivot\collections\ArrayList.java
Sending core\src\org\apache\pivot\collections\EnumList.java
Adding core\src\org\apache\pivot\collections\ReadOnlySequence.java
Sending core\src\org\apache\pivot\collections\immutable\ImmutableList.java
Sending core\test\org\apache\pivot\collections\test\ArrayListTest.java
Sending wtk\src\org\apache\pivot\wtk\content\NumericSpinnerData.java
Transmitting file data .......done
Committing transaction...
Committed revision 1864990.

> Refactor read-only classes to use a common abstract class to reduce code
> ------------------------------------------------------------------------
>
>                 Key: PIVOT-1045
>                 URL: https://issues.apache.org/jira/browse/PIVOT-1045
>             Project: Pivot
>          Issue Type: Improvement
>          Components: core-collections
>            Reporter: Roger Whitcomb
>            Assignee: Roger Whitcomb
>            Priority: Minor
>
> All of the "read-only" collections (such as ArrayAdapter, EnumList, ImmutableList) share the concept that "add", "insert", "remove", etc. all throw an exception because they are unsupported in a read-only collection. It would reduce code and expose the common functionality if they were all implemented on top of a single abstract class the provides a uniform implementation of these unsupported methods.
> I propose to implement a ReadOnlySequence class that does this and refactor all other existing places (at least) with the common subclass.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)